ath79: correct Siemens WS-AP3610 blocksize
authorDavid Bauer <mail@david-bauer.net>
Thu, 20 Feb 2020 09:29:09 +0000 (10:29 +0100)
committerDavid Bauer <mail@david-bauer.net>
Thu, 20 Feb 2020 09:41:12 +0000 (10:41 +0100)
With the wrong blocksize, the rootfs was not positioned on the boundary
of a block, thus breaking the mtdsplit driver.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/image/generic.mk

index d4693cea68f60c26f21858af76a88efe142ad26f..1fa9b30c518fa9ba3507cc56d5e3bc74b5de431b 100644 (file)
@@ -1046,6 +1046,7 @@ define Device/siemens_ws-ap3610
   DEVICE_VENDOR := Siemens
   DEVICE_MODEL := WS-AP3610
   IMAGE_SIZE := 14336k
+  BLOCKSIZE := 256k
   LOADER_TYPE := bin
   LOADER_FLASH_OFFS := 0x82000
   COMPILE := loader-$(1).bin