toolchain: Add libatomic when using external toolchain
authorJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 13:58:03 +0000 (13:58 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 13:58:03 +0000 (13:58 +0000)
Otherwise libatomic cannot be used in conjunction with external toolchains.

Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
SVN-Revision: 43998

package/libs/toolchain/Makefile

index 1a75e90c30f223136302e35703ed10af9b47d9bc..42b9935148fff347f97823d83a8aeba633e25477 100644 (file)
@@ -604,6 +604,15 @@ else
        exit 0
   endef
 
+  define Package/libatomic/install
+       for file in $(call qstrip,$(CONFIG_LIBATOMIC_FILE_SPEC)); do \
+               dir=`dirname $$$$file` ; \
+               $(INSTALL_DIR) $(1)/$$$$dir ; \
+               $(CP) $(call qstrip,$(CONFIG_LIBATOMIC_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
+       done ; \
+       exit 0
+  endef
+
   define Package/ldd/install
        for file in $(call qstrip,$(CONFIG_LDD_FILE_SPEC)); do \
                dir=`dirname $$$$file` ; \