ag71xx driver: add a workaround for the ar8216 chip, until we get a suitable switch...
authorGabor Juhos <juhosg@openwrt.org>
Wed, 25 Feb 2009 16:47:11 +0000 (16:47 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 25 Feb 2009 16:47:11 +0000 (16:47 +0000)
SVN-Revision: 14655

target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/platform.h
target/linux/ar71xx/files/drivers/net/ag71xx/Kconfig
target/linux/ar71xx/files/drivers/net/ag71xx/Makefile
target/linux/ar71xx/files/drivers/net/ag71xx/ag71xx.h
target/linux/ar71xx/files/drivers/net/ag71xx/ag71xx_main.c

index f2fcc47d8dc6e2a1ce5687db41c1755f2824e232..17d7c0b441c72b3206fda55af303a22f1238b157 100644 (file)
@@ -4,6 +4,7 @@ CONFIG_32BIT=y
 CONFIG_ADM6996_PHY=y
 CONFIG_AG71XX=y
 # CONFIG_AG71XX_DEBUG is not set
+CONFIG_AG71XX_AR8216_SUPPORT=y
 # CONFIG_AR71XX_EARLY_SERIAL is not set
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
index a3448f5a8b29890b91f0c3f187c9e5f7c6ec4791..672da31c83e8236b691b5fcc66e1dfc773146f30 100644 (file)
@@ -28,6 +28,7 @@ struct ag71xx_platform_data {
 
        u8              has_gbit:1;
        u8              is_ar91xx:1;
+       u8              has_ar8216:1;
 
        void            (* ddr_flush)(void);
        void            (* set_pll)(u32 pll);
index 18be11593cd6fa928b6bc24afa488dd62374cb48..56a59648cf2eed044afd12ad54200c3d8fba8f64 100644 (file)
@@ -12,3 +12,12 @@ config AG71XX_DEBUG
        default n
        help
          Atheros AR71xx built-in ethernet driver debugging messages.
+
+config AG71XX_AR8216_SUPPORT
+       bool "special support for the Atheros AR8216 switch"
+       depends on AG71XX
+       default n
+       default y if AR71XX_MACH_WNR2000 || AR71XX_MACH_MZK_W04NU
+       help
+         Say 'y' here if you want to enable special support for the
+         Atheros AR8216 switch found on some boards.
index 37c98d22a3ff7c440c4ae787731a4888a023ce36..aa1798d1957d965d6728954235432f7a421e0a17 100644 (file)
@@ -2,6 +2,12 @@
 # Makefile for the Atheros AR71xx built-in ethernet macs
 #
 
+ag71xx-y       += ag71xx_main.o 
+ag71xx-y       += ag71xx_ethtool.o 
+ag71xx-y       += ag71xx_phy.o 
+ag71xx-y       += ag71xx_mdio.o
+
+ag71xx-$(CONFIG_AG71XX_AR8216_SUPPORT) += ag71xx_ar8216.o
+
 obj-$(CONFIG_AG71XX)   += ag71xx.o
 
-ag71xx-objs    := ag71xx_main.o ag71xx_ethtool.o ag71xx_phy.o ag71xx_mdio.o
index 3dbb453fc5b0ca682223cb2dcc9865be35e626f3..1d22453a977f52a9802f2794fbfecb881a193283 100644 (file)
@@ -38,7 +38,7 @@
 #define ETH_FCS_LEN    4
 
 #define AG71XX_DRV_NAME                "ag71xx"
-#define AG71XX_DRV_VERSION     "0.5.20"
+#define AG71XX_DRV_VERSION     "0.5.21"
 
 #define AG71XX_NAPI_WEIGHT     64
 #define AG71XX_OOM_REFILL      (1 + HZ/10)
@@ -430,4 +430,20 @@ static void inline ag71xx_mii_ctrl_set_speed(struct ag71xx *ag,
        ag71xx_mii_ctrl_wr(ag, t);
 }
 
+#ifdef CONFIG_AG71XX_AR8216_SUPPORT
+void ag71xx_add_ar8216_header(struct ag71xx *ag, struct sk_buff *skb);
+int ag71xx_remove_ar8216_header(struct ag71xx *ag, struct sk_buff *skb);
+#else
+static inline void ag71xx_add_ar8216_header(struct ag71xx *ag,
+                                          struct sk_buff *skb)
+{
+}
+
+static inline int ag71xx_remove_ar8216_header(struct ag71xx *ag,
+                                             struct sk_buff *skb)
+{
+       return 0;
+}
+#endif
+
 #endif /* _AG71XX_H */
index 01834887c5f0e9332a4abbacc10d783cbb6eff3c..e5eced228666edeb6ba4652554984911be339d1b 100644 (file)
@@ -473,6 +473,8 @@ static int ag71xx_hard_start_xmit(struct sk_buff *skb, struct net_device *dev)
        if (!ag71xx_desc_empty(desc))
                goto err_drop;
 
+       ag71xx_add_ar8216_header(ag, skb);
+
        if (skb->len <= 0) {
                DBG("%s: packet len is too small\n", ag->dev->name);
                goto err_drop;
@@ -647,15 +649,20 @@ static int ag71xx_rx_packets(struct ag71xx *ag, int limit)
                skb_put(skb, pktlen);
 
                skb->dev = dev;
-               skb->protocol = eth_type_trans(skb, dev);
                skb->ip_summed = CHECKSUM_NONE;
 
-               netif_receive_skb(skb);
-
                dev->last_rx = jiffies;
                dev->stats.rx_packets++;
                dev->stats.rx_bytes += pktlen;
 
+               if (ag71xx_remove_ar8216_header(ag, skb) != 0) {
+                       dev->stats.rx_dropped++;
+                       kfree_skb(skb);
+               } else {
+                       skb->protocol = eth_type_trans(skb, dev);
+                       netif_receive_skb(skb);
+               }
+
                ring->buf[i].skb = NULL;
                done++;