kernel: Enable hwmon for nvme
authorLuca Barbato <lu_zero@gentoo.org>
Tue, 8 Aug 2023 09:02:41 +0000 (11:02 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 26 Oct 2023 20:19:58 +0000 (22:19 +0200)
Expose the temperature sensors as hwmon, it improves the overall
user experience since on tiny boards the nvme can become a substantial
source of heat.

Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Reviewed-by: Robert Marko <robimarko@gmail.com>
package/kernel/linux/modules/block.mk

index 4ee3f78f3809a25d0442b7c0e3512ed6c284f072..5e6eefa76a94916ae8ef9c842bb361e6885eaa81 100644 (file)
@@ -496,12 +496,12 @@ $(eval $(call KernelPackage,nbd))
 define KernelPackage/nvme
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=NVM Express block device
-  DEPENDS:=@PCI_SUPPORT
+  DEPENDS:=@PCI_SUPPORT +kmod-hwmon-core
   KCONFIG:= \
        CONFIG_NVME_CORE \
        CONFIG_BLK_DEV_NVME \
        CONFIG_NVME_MULTIPATH=n \
-       CONFIG_NVME_HWMON=n
+       CONFIG_NVME_HWMON=y
   FILES:= \
        $(LINUX_DIR)/drivers/nvme/host/nvme-core.ko \
        $(LINUX_DIR)/drivers/nvme/host/nvme.ko