w1-gpio-custom: set enable_external_pullup to null (#8952)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 7 Aug 2012 16:08:08 +0000 (16:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 7 Aug 2012 16:08:08 +0000 (16:08 +0000)
SVN-Revision: 33034

package/w1-gpio-custom/Makefile
package/w1-gpio-custom/src/w1-gpio-custom.c

index c1441e9caa312ee537fb35abd11c00d6b43121a9..bf50d1a50f0865484075473892603487e7d3f1bd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=w1-gpio-custom
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
index 8f739d49fd491f48ad54ab088c34486421de63f6..96cfcabc610703cba707d2fbf5f95567b28fbb54 100644 (file)
@@ -112,6 +112,7 @@ static int __init w1_gpio_custom_add_one(unsigned int id, unsigned int *params)
 
        pdata.pin = params[BUS_PARAM_PIN];
        pdata.is_open_drain = params[BUS_PARAM_OD] ? 1:0;
+       pdata.enable_external_pullup = NULL;
 
        err = platform_device_add_data(pdev, &pdata, sizeof(pdata));
        if (err)