lldpd: add Build/InstallDev rule
authorJohn Crispin <john@openwrt.org>
Sat, 21 Mar 2015 21:47:34 +0000 (21:47 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 21 Mar 2015 21:47:34 +0000 (21:47 +0000)
For using liblldpctl to talk to lldpd (via unix sockets).

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
SVN-Revision: 44924

package/network/services/lldpd/Makefile

index f038a340ac5f8c24de1ed0ef9ed6b72f7c9412d5..ff367f1c3e78c3792656b6aab1bd27888e75bf01 100644 (file)
@@ -49,6 +49,14 @@ define Package/lldpd/description
        Link-Layer notifications to adjacent network devices.
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldpctl.h $(1)/usr/include/lldpctl.h
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldp-const.h $(1)/usr/include/lldp-const.h
+endef
+
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/lldpd.d