uboot-fritz4040: Fix build with HOSTCFLAGS
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Feb 2018 23:52:08 +0000 (00:52 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Feb 2018 23:56:50 +0000 (00:56 +0100)
When we provide the HOSTCFLAGS to the U-Boot build it will fail because
it can not find the u-boot provided header files any more.
Just overwrite and not append the package specific configuration on top
of the configuration provided by u-boot.mk.
uboot-fritz4040 is based on U-Boot 2012.07 and this problem is probably
similar to the problem seen with the lantiq and ar71xx u-boot build.

Fixes: df9781a4205 ("u-boot,at91bootstrap: fix incorrect HOSTCPPFLAGS variable")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-fritz4040/Makefile

index 9f9b4e05f4aa3dd14d5c1ffeacbc11f343a37371..4a36c55095e972f925c9a2c742bcece0283f6ac5 100644 (file)
@@ -29,7 +29,7 @@ define U-Boot/fritz4040
 endef
 
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
-UBOOT_MAKE_FLAGS += USE_PRIVATE_LIBGCC=yes
+UBOOT_MAKE_FLAGS = USE_PRIVATE_LIBGCC=yes
 export DTC
 
 define Build/Configure