fix inclusion of kernel modules selected for install in images (closes: #598).
authorNicolas Thill <nico@openwrt.org>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 25 Jun 2006 21:37:07 +0000 (21:37 +0000)
SVN-Revision: 4081

openwrt/include/kernel.mk

index c110f687a341daa3959b0e3a52211eecf0936fb4..b40f65f480dc9fa294c04184152014449ecb1eb0 100644 (file)
@@ -47,10 +47,10 @@ PKG_$(1) := $(PACKAGE_DIR)/kmod-$(2)_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)_
 I_$(1) := $(KMOD_BUILD_DIR)/ipkg/$(2)
 
 ifeq ($$(KDEPEND_$(1)),m)
-ifneq ($(CONFIG_PACKAGE_KMOD_$(1)),)
+ifneq ($$(CONFIG_PACKAGE_KMOD_$(1)),)
 TARGETS += $$(PKG_$(1))
 endif
-ifeq ($(CONFIG_PACKAGE_KMOD_$(1)),y)
+ifeq ($$(CONFIG_PACKAGE_KMOD_$(1)),y)
 INSTALL_TARGETS += $$(PKG_$(1))
 endif
 endif