base-files: fix option parsing of -F/--force parameter
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Aug 2012 18:30:47 +0000 (18:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Aug 2012 18:30:47 +0000 (18:30 +0000)
SVN-Revision: 33075

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 27b5e33dd32dcc4533a9079603d6ccac97a8eb4b..bb88d5d32ddfb3dcb89015f60e0686b418c3eec0 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=113
+PKG_RELEASE:=114
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 3868dc456e93e23eea04e6ed59113b79239b831c..62a4012a328010823e6578fe91d822eed2d22bcf 100755 (executable)
@@ -25,7 +25,7 @@ while [ -n "$1" ]; do
                -c) export SAVE_OVERLAY=1;;
                -b|--create-backup) export CONF_BACKUP="$2"; shift;;
                -f) export CONF_IMAGE="$2"; shift;;
-               -F|--force) export FORCE=1; shift;;
+               -F|--force) export FORCE=1;;
                -h|--help) export HELP=1; break;;
                -*)
                        echo "Invalid option: $1"