ixp4xx: add Titan Wireless 266-2
authorZoltan HERPAI <wigyori@uid0.hu>
Fri, 21 May 2021 22:04:55 +0000 (00:04 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Thu, 21 Apr 2022 07:18:35 +0000 (09:18 +0200)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/ixp4xx/patches-5.10/152-ARM-dts-add-tw2662.patch [new file with mode: 0644]

diff --git a/target/linux/ixp4xx/patches-5.10/152-ARM-dts-add-tw2662.patch b/target/linux/ixp4xx/patches-5.10/152-ARM-dts-add-tw2662.patch
new file mode 100644 (file)
index 0000000..d009696
--- /dev/null
@@ -0,0 +1,116 @@
+diff -ruN a/arch/arm/boot/dts/intel-ixp42x-titanwireless-tw2662.dts b/arch/arm/boot/dts/intel-ixp42x-titanwireless-tw2662.dts
+--- a/arch/arm/boot/dts/intel-ixp42x-titanwireless-tw2662.dts  1970-01-01 01:00:00.000000000 +0100
++++ b/arch/arm/boot/dts/intel-ixp42x-titanwireless-tw2662.dts  2021-05-20 23:48:13.602479932 +0200
+@@ -0,0 +1,101 @@
++// SPDX-License-Identifier: ISC
++/*
++ * Device Tree file for Titan Wireless TW266-2
++ * Copyright (c) 2021 Zoltan HERPAI <wigyori@uid0.hu>
++ */
++
++/dts-v1/;
++
++#include "intel-ixp42x.dtsi"
++#include <dt-bindings/input/input.h>
++
++/ {
++      model = "Titan Wireless 266-2";
++      compatible = "titanwireless,tw266", "intel,ixp42x";
++      #address-cells = <1>;
++      #size-cells = <1>;
++
++      memory@0 {
++              /* 64 MB SDRAM */
++              device_type = "memory";
++              reg = <0x00000000 0x4000000>;
++      };
++
++      chosen {
++              /* mem=64M taken from the tw2662-setup.c boardfile */
++              bootargs = "console=ttyS0,115200n8";
++              stdout-path = "uart0:115200n8";
++      };
++
++/*    i2c {
++              compatible = "i2c-gpio";
++              sda-gpios = <&gpio0 7 (GPIO_ACTIVE_HIGH|GPIO_OPEN_DRAIN)>;
++              scl-gpios = <&gpio0 6 (GPIO_ACTIVE_HIGH|GPIO_OPEN_DRAIN)>;
++              #address-cells = <1>;
++              #size-cells = <0>;
++      };
++*/
++      aliases {
++              serial0 = &uart0;
++      };
++
++      soc {
++              bus@50000000 {
++                      /* The first 16MB region at CS0 on the expansion bus */
++                      flash@0 {
++                              compatible = "intel,ixp4xx-flash", "cfi-flash";
++                              bank-width = <2>;
++                              /*
++                               * 16 MB of Flash in 0x20000 byte blocks
++                               * mapped in at CS0.
++                               */
++                              reg = <0x00000000 0x1000000>;
++
++                              partitions {
++                                      compatible = "redboot-fis";
++                                      /* Eraseblock at 0x7e0000 */
++                                      fis-index-block = <0x7f>;
++                              };
++                      };
++              };
++
++              pci@c0000000 {
++                      status = "ok";
++
++                      interrupt-map =
++                      /* IDSEL 1 */
++                      <0x0800 0 0 1 &gpio0 11 3>, /* INT A on slot 1 is irq 11 */
++                      /* IDSEL 3 */
++                      <0x1800 0 0 1 &gpio0 9  3>; /* INT A on slot 3 is irq 9 */
++              };
++
++              ethernet@c8009000 {
++                      status = "ok";
++                      queue-rx = <&qmgr 3>;
++                      queue-txready = <&qmgr 20>;
++                      phy-mode = "rgmii";
++                      phy-handle = <&phy3>;
++
++                      mdio {
++                              #address-cells = <1>;
++                              #size-cells = <0>;
++
++                              phy1: ethernet-phy@1 {
++                                      reg = <1>;
++                              };
++
++                              phy3: ethernet-phy@3 {
++                                      reg = <3>;
++                              };
++                      };
++              };
++
++              ethernet@c800a000 {
++                      status = "ok";
++                      queue-rx = <&qmgr 4>;
++                      queue-txready = <&qmgr 21>;
++                      phy-mode = "rgmii";
++                      phy-handle = <&phy1>;
++              };
++      };
++};
+diff -ruN a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile       2021-05-19 17:41:15.911243339 +0200
++++ b/arch/arm/boot/dts/Makefile       2021-05-20 17:27:15.111961454 +0200
+@@ -247,6 +247,7 @@
+       intel-ixp42x-adi-pronghorn-metro.dtb \
+       intel-ixp42x-gateway-7001.dtb \
+       intel-ixp42x-linksys-nslu2.dtb \
++      intel-ixp42x-titanwireless-tw2662.dtb \
+       intel-ixp43x-gateworks-gw2358.dtb
+ dtb-$(CONFIG_ARCH_KEYSTONE) += \
+       keystone-k2hk-evm.dtb \