tools/cmake: update to 3.8.1
authorHannu Nyman <hannu.nyman@iki.fi>
Mon, 8 May 2017 19:18:25 +0000 (22:18 +0300)
committerFelix Fietkau <nbd@nbd.name>
Thu, 25 May 2017 17:01:07 +0000 (19:01 +0200)
* update cmake to 3.8.1
* refresh patches

Release notes:
https://cmake.org/cmake/help/v3.8/release/3.8.html

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
tools/cmake/Makefile
tools/cmake/patches/100-disable_qt_tests.patch
tools/cmake/patches/110-freebsd-compat.patch
tools/cmake/patches/140-curl-fix-libressl-linking.patch
tools/cmake/patches/150-bootstrap_parallel_make_flag.patch

index cd9e7c16fc4f30df342bfe1d042c0970bd848163..a94942f84c995399fd568f82df49f88eb8c3e8b6 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.7.2
+PKG_VERSION:=3.8.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.7/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.8/ \
                https://fossies.org/linux/misc/
-PKG_HASH:=dc1246c4e6d168ea4d6e042cfba577c1acd65feea27e56f5ff37df920c30cae0
+PKG_HASH:=ce5d9161396e06501b00e52933783150a87c33080d4bdcef461b5b7fd24ac228
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index 6f28c435e018f53fedc3ba840298b6aaf8a07e9b..54a75bc7762f44001426dc227867d27fce25bb6b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Tests/RunCMake/CMakeLists.txt
 +++ b/Tests/RunCMake/CMakeLists.txt
-@@ -225,15 +225,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -244,15 +244,6 @@ add_RunCMake_test(no_install_prefix)
  add_RunCMake_test(configure_file)
  add_RunCMake_test(CTestTimeoutAfterMatch)
  
@@ -18,7 +18,7 @@
    add_RunCMake_test(FindPkgConfig)
 --- a/Tests/CMakeLists.txt
 +++ b/Tests/CMakeLists.txt
-@@ -393,10 +393,6 @@ if(BUILD_TESTING)
+@@ -398,10 +398,6 @@ if(BUILD_TESTING)
  
    list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
  
index c1d4a274d61c3c0b81288ba4260abd34ce76063c..4f110784612934020c83167c0859de73eb58806e 100644 (file)
@@ -21,10 +21,10 @@ Change-Id: I3b91ed7ac0e6878035aee202b3336c536cc6d2ff
 
 --- a/Source/kwsys/SystemInformation.cxx
 +++ b/Source/kwsys/SystemInformation.cxx
-@@ -89,6 +89,15 @@ typedef int siginfo_t;
- #  include <ifaddrs.h>
- #  define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
- # endif
+@@ -82,6 +82,15 @@ typedef int siginfo_t;
+ #include <net/if.h>
+ #define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
+ #endif
 +# if defined(KWSYS_SYSTEMINFORMATION_HAS_BACKTRACE)
 +#  include <execinfo.h>
 +#  if defined(KWSYS_SYSTEMINFORMATION_HAS_CPP_DEMANGLE)
index 5b57172eb4a147d25be01b105dd49599f1add4e6..c16e927ff3fb8a647c2d8d5f4b232714467c91e2 100644 (file)
@@ -19,7 +19,7 @@ and unconditionally link the rt library when the symbol is found.
 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 --- a/Utilities/cmcurl/CMakeLists.txt
 +++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -362,6 +362,10 @@ set(HAVE_LIBSSL OFF)
+@@ -374,6 +374,10 @@ set(HAVE_LIBSSL OFF)
  if(CMAKE_USE_OPENSSL)
    find_package(OpenSSL)
    if(OPENSSL_FOUND)
index 6970b83b327c348d31d74dc5facba4fad46fe700..4d432dcc1ef8d7af184178a96c7621bbad7a70c6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/bootstrap
 +++ b/bootstrap
-@@ -958,7 +958,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1046,7 +1046,10 @@ int main(){ printf("1%c", (char)0x0a); r
  ' > "test.c"
  cmake_original_make_flags="${cmake_make_flags}"
  if [ "x${cmake_parallel_make}" != "x" ]; then