om-watchdog: fix board name for teltonika,rut5xx
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 7 Aug 2020 14:29:23 +0000 (16:29 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 7 Aug 2020 14:30:55 +0000 (16:30 +0200)
The board name is equivalent to the compatible, not the device
definition. Fix it.

Fixes: b4588c853838 ("kernel/om-watchdog: Apply device renames from ramips")
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/kernel/om-watchdog/Makefile
package/kernel/om-watchdog/files/om-watchdog.init

index a7e859dc8b5b498e2b15ec21fffff9211fd268e9..6f2ac372fbcd3d71eab801bbd97bbc0c532c5bd3 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=om-watchdog
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
index 4c407dadaeb719e055b4ff0f32522f8c61f39c78..12ff66583761528f24db15a2c08cd929f91ab1e0 100644 (file)
@@ -47,7 +47,7 @@ get_gpio() {
                        return 17
                        ;;
                esac
-       elif [ "$board" = "teltonika_rut5xx" ]; then
+       elif [ "$board" = "teltonika,rut5xx" ]; then
                # ramips
                return 11
        else