realtek: fix GS1900-48 firwmare partition
authorSander Vanheule <sander@svanheule.net>
Wed, 28 Dec 2022 11:26:21 +0000 (12:26 +0100)
committerSander Vanheule <sander@svanheule.net>
Wed, 28 Dec 2022 21:44:10 +0000 (22:44 +0100)
The listed partition size doesn't match the original partition size, and
actually overlaps with the following partition. The partition node name
for the "firmware" partition also has an extra 'b' compared to the
partition offset.

Fixes: 47f5a0a3eed5 ("realtek: Add support for ZyXEL GS1900-48 Switch")
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/realtek/dts-5.10/rtl8393_zyxel_gs1900-48.dts
target/linux/realtek/dts-5.15/rtl8393_zyxel_gs1900-48.dts
target/linux/realtek/image/rtl839x.mk

index dd392c5a9beb13f11f9492288ec0d1e47d53bf17..48cfae67030312413953856158aa5ab39109bcbd 100644 (file)
                                label = "jffs2";
                                reg = <0x160000 0x100000>;
                        };
-                       partition@b260000 {
+                       partition@260000 {
                                label = "firmware";
-                               reg = <0x260000 0xda0000>;
+                               reg = <0x260000 0x6d0000>;
                                compatible = "openwrt,uimage", "denx,uimage";
                                openwrt,ih-magic = <0x83800000>;
                        };
index dd392c5a9beb13f11f9492288ec0d1e47d53bf17..48cfae67030312413953856158aa5ab39109bcbd 100644 (file)
                                label = "jffs2";
                                reg = <0x160000 0x100000>;
                        };
-                       partition@b260000 {
+                       partition@260000 {
                                label = "firmware";
-                               reg = <0x260000 0xda0000>;
+                               reg = <0x260000 0x6d0000>;
                                compatible = "openwrt,uimage", "denx,uimage";
                                openwrt,ih-magic = <0x83800000>;
                        };
index 95dae0f861706acf04ae9ca5ef3ff7f4111b6bd0..b5e669fce4b252fa7332b0bf7dd8692410c0c69c 100644 (file)
@@ -38,7 +38,7 @@ TARGET_DEVICES += tplink_sg2452p-v4
 
 define Device/zyxel_gs1900-48
   SOC := rtl8393
-  IMAGE_SIZE := 13952k
+  IMAGE_SIZE := 6976k
   DEVICE_VENDOR := ZyXEL
   UIMAGE_MAGIC := 0x83800000
   ZYXEL_VERS := AAHN