ar71xx: do not throw compile errors if the nbg460n uboot is not selected
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 Dec 2010 16:07:27 +0000 (16:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 Dec 2010 16:07:27 +0000 (16:07 +0000)
SVN-Revision: 24426

target/linux/ar71xx/image/Makefile

index 4c96a88bcf6b198ddf5407368c5a671eaa596cf9..44c030e4e07c040acfb477d5ee6937ed6e2a6720 100644 (file)
@@ -373,7 +373,8 @@ define Image/Build/WNDR3700
                -o $(call imgname,$(1),$(2))-factory.img
 endef
 
-define Image/Build/ZyXEL
+ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
+  define Image/Build/ZyXEL
        $(call PatchKernelLzma,$(2),$(3))
        if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
                echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
@@ -394,7 +395,8 @@ define Image/Build/ZyXEL
                        -r $(call imgname,$(1),$(2))-sysupgrade.bin:0x10000 \
                        -o $(call imgname,$(1),$(2))-factory.bin; \
        fi; fi
-endef
+  endef
+endif
 
 define Image/Build/WNDR3700/initramfs
        $(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))