ath79: Add support for Ubiquiti LiteAP ac (LAP-120)
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>
Wed, 19 Sep 2018 12:17:35 +0000 (14:17 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 28 Oct 2018 09:59:09 +0000 (10:59 +0100)
This commit adds support for the Ubiquiti LiteAP ac (LAP-120), an outdoor
5 GHz AC access point with an integrated 120° 16 dBi antenna. The device
was previously known as LiteBeam AP ac but was later rebranded.

CPU:    Atheros AR9342 SoC
RAM:    64 MB DDR2
Flash:  16 MB NOR SPI
Ports:  1 GbE port (PoE in)
WLAN:   5 GHz QCA899X (PCI)

The integrated QCA899X is a Ubiquiti branded part with modified vendor
and product id (0777:11ac9). It is very similar to the NanoStation loco
AC, except for the 2.4 GHz management radio (missing here).

Installation procedure is the same as the NanoStation [loco] AC:

1. Connect to serial header on device
2. Power on device and enter uboot console
3. Set up tftp server serving an openwrt initramfs build
4. Load initramfs build using the command tftpboot in the uboot cli
5. Boot the loaded image using the command bootm
6. Copy squashfs openwrt sysupgrade build to the booted device
7. Use mtd to write sysupgrade to partition "firmware"
8. Reboot and enjoy

Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/ar9342_ubnt_lap-120.dts [new file with mode: 0644]
target/linux/ath79/image/generic-ubnt.mk

index 56eb42f65c948f45b61f724c07e42825afd2f105..b4699933da98ad84b38b79e11a627d1efd5bab13 100755 (executable)
@@ -21,6 +21,7 @@ ath79_setup_interfaces()
        tplink,tl-wa901nd-v2|\
        tplink,tl-wr703n|\
        ubnt,bullet-m|\
+       ubnt,lap-120|\
        ubnt,nanostation-ac-loco|\
        ubnt,rocket-m|\
        ubnt,unifiac-lite|\
index 9365d67e8534309eed8d37986e7f13334849f971..dfe2d3ef3199628863eabd69e48bc091f4358521 100644 (file)
@@ -111,6 +111,7 @@ case "$FIRMWARE" in
        ubnt,unifiac-lite|\
        ubnt,unifiac-mesh|\
        ubnt,unifiac-mesh-pro|\
+       ubnt,lap-120|\
        ubnt,nanostation-ac|\
        ubnt,nanostation-ac-loco|\
        ubnt,unifiac-pro)
diff --git a/target/linux/ath79/dts/ar9342_ubnt_lap-120.dts b/target/linux/ath79/dts/ar9342_ubnt_lap-120.dts
new file mode 100644 (file)
index 0000000..26b734e
--- /dev/null
@@ -0,0 +1,43 @@
+// SPDX-License-Identifier: GPL-2.0
+/dts-v1/;
+
+#include <dt-bindings/input/input.h>
+
+#include "ar9342_ubnt_wa.dtsi"
+
+/ {
+       compatible = "ubnt,lap-120", "ubnt,wa";
+       model = "Ubiquiti LiteAP ac (LAP-120)";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <4>;
+       phy4: ethernet-phy@4 {
+               phy-mode = "rgmii";
+               reg = <4>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       /* default for ar934x, except for 1000M and 10M */
+       pll-data = <0x06000000 0x00000101 0x00001313>;
+
+       mtd-mac-address = <&eeprom 0x0>;
+
+       phy-mode = "rgmii";
+       phy-handle = <&phy4>;
+
+       gmac-config {
+               device = <&gmac>;
+               rxd-delay = <3>;
+               rxdv-delay = <3>;
+       };
+};
+
+&wmac {
+       status = "disabled";
+};
index 8cdd5a2d2fddec1c0bfb520768bd5c247f85c7c5..bb86c8b2884ba181c62d4bbecd351acfbd4c659b 100644 (file)
@@ -84,6 +84,15 @@ define Device/ubnt_nano-m
 endef
 TARGET_DEVICES += ubnt_nano-m
 
+define Device/ubnt_lap-120
+  $(Device/ubnt-wa)
+  DEVICE_TITLE := Ubiquiti LiteAP ac (LAP-120)
+  DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+  IMAGE_SIZE := 15744k
+  IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+endef
+TARGET_DEVICES += ubnt_lap-120
+
 define Device/ubnt_nanostation-ac
   $(Device/ubnt-wa)
   DEVICE_TITLE := Ubiquiti Nanostation AC