kernel: fix kmod-usb-phy-omap-usb2
authorJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:25 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:25 +0000 (14:31 +0000)
upstream change in Kernel 3.18
commit: "phy: rename struct omap_control_usb to struct omap_control_phy"

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45234

package/kernel/linux/modules/usb.mk

index 53a0c9cd49dd3f6bf11c3dfa916272827fffc4da..bfe952ff7852ed21e4ab152d81d47419d9606cf1 100644 (file)
@@ -150,11 +150,11 @@ define KernelPackage/usb-phy-omap-usb2
   TITLE:=Support for OMAP2 USB PHY
   KCONFIG:= \
        CONFIG_OMAP_USB2 \
-       CONFIG_OMAP_CONTROL_USB
+       CONFIG_OMAP_CONTROL_PHY
   DEPENDS:=@TARGET_omap
   FILES:= \
        $(LINUX_DIR)/drivers/phy/phy-omap-usb2.ko \
-       $(LINUX_DIR)/drivers/usb/phy/phy-omap-control.ko
+       $(LINUX_DIR)/drivers/phy/phy-omap-control.ko
   AUTOLOAD:=$(call AutoLoad,45,phy-omap-control phy-omap-usb2)
   $(call AddDepends/usb)
 endef