ramips: add a profile for AWM003
authorJohn Crispin <john@openwrt.org>
Tue, 22 Jul 2014 09:58:21 +0000 (09:58 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 22 Jul 2014 09:58:21 +0000 (09:58 +0000)
same as AWM002 but with 64mb RAM

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41797

target/linux/ramips/dts/AWM003-EVB.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/asiarf.mk

diff --git a/target/linux/ramips/dts/AWM003-EVB.dts b/target/linux/ramips/dts/AWM003-EVB.dts
new file mode 100644 (file)
index 0000000..08157f5
--- /dev/null
@@ -0,0 +1,59 @@
+/dts-v1/;
+
+/include/ "AWM002-8M.dtsi"
+
+/ {
+       compatible = "AWM003", "ralink,rt5350-soc";
+       model = "AsiaRF AWM003 EVB";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x4000000>;
+       };
+
+       palmbus@10000000 {
+               spi@b00 {
+                       m25p80@0 {
+                               compatible = "mx25l6405d";
+                               linux,modalias = "m25p80", "mx25l6405d";
+                       };
+               };
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               tx {
+                       label = "awm002-evb:green:tx";
+                       gpios = <&gpio0 15 1>;
+               };
+               rx {
+                       label = "awm002-evb:green:rx";
+                       gpios = <&gpio0 16 1>;
+               };
+               wps {
+                       label = "awm002-evb:green:wps";
+                       gpios = <&gpio0 21 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset_wps {
+                       label = "reset_wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x198>;
+               };
+               mode {
+                       label = "mode";
+                       gpios = <&gpio0 21 1>;
+                       linux,code = <0x32>;
+               };
+       };
+};
index c7225a6a39a7da867856466f9b596fbaa7e9a9b5..ef019ef2f7b22e93590e9154adbff8cb252e3acf 100644 (file)
@@ -348,6 +348,7 @@ endef
 Image/Build/Profile/ASL26555=$(call BuildFirmware/ASL26555/$(1),$(1),asl26555,ASL26555)
 
 Image/Build/Profile/AWM002EVB=$(call BuildFirmware/DefaultDualSize/$(1),$(1),awm002-evb,AWM002-EVB)
+Image/Build/Profile/AWM003EVB=$(call BuildFirmware/Default8M/$(1),$(1),awm003-evb,AWM003-EVB)
 Image/Build/Profile/AWAPN2403=$(call BuildFirmware/Default4M/$(1),$(1),awmapn2403,AWAPN2403)
 
 Image/Build/Profile/BC2=$(call BuildFirmware/Default8M/$(1),$(1),bc2,BC2)
index 8aef8a8e4b5523ce64f00ae530c09f1665c512db..a0bd38575d558b46e5013a11f62889121150b16b 100644 (file)
@@ -8,13 +8,23 @@
 define Profile/AWM002EVB
        NAME:=AsiaRF AWM002-EVB
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
-       kmod-i2c-core kmod-i2c-gpio
+               kmod-i2c-core kmod-i2c-gpio
 endef
 
 define Profile/AWM002EVB/Description
        Package set for AsiaRF AWM002 Evaluation Board
 endef
 
+define Profile/AWM003EVB
+       NAME:=AsiaRF AWM003-EVB
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+               kmod-i2c-core kmod-i2c-gpio
+endef
+
+define Profile/AWM003EVB/Description
+       Package set for AsiaRF AWM003 Evaluation Board
+endef
+
 define Profile/AWAPN2403
        NAME:=AsiaRF AWAPN2403
 endef
@@ -24,4 +34,5 @@ define Profile/AWAPN2403/Description
 endef
 
 $(eval $(call Profile,AWM002EVB))
+$(eval $(call Profile,AWM003EVB))
 $(eval $(call Profile,AWAPN2403))