modules: make ahci-platform depend on TARGET_ipq806x
authorJohn Crispin <john@openwrt.org>
Wed, 25 Feb 2015 12:01:19 +0000 (12:01 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 25 Feb 2015 12:01:19 +0000 (12:01 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 44534

package/kernel/linux/modules/block.mk

index 159155e049bfe8a9d6353addd04fcf2b6390f02d..46cb99c8344d633dd62d2f0b433a5656a5dd5f82 100644 (file)
@@ -63,7 +63,7 @@ define KernelPackage/ata-ahci-platform
     $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
     $(LINUX_DIR)/drivers/ata/libahci_platform.ko
   AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
-  $(call AddDepends/ata,+kmod-ata-ahci)
+  $(call AddDepends/ata,@TARGET_ipq806x +kmod-ata-ahci)
 endef
 
 define KernelPackage/ata-ahci-platform/description