kernel: add packaging for Xeon iTCO watchdog timer
authorPhilip Prindeville <philipp@redfish-solutions.com>
Fri, 15 Sep 2017 17:03:52 +0000 (11:03 -0600)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 16 Sep 2017 22:08:00 +0000 (00:08 +0200)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
package/kernel/linux/modules/other.mk
target/linux/x86/64/config-default

index 1b31a861f07516089b3d2e9323f594cba2aa5423..e4b2064dc469e8a043809fec81f7015e2b88bedd 100644 (file)
@@ -1044,3 +1044,20 @@ define KernelPackage/w83627hf-wdt/description
 endef
 
 $(eval $(call KernelPackage,w83627hf-wdt))
+
+
+define KernelPackage/itco-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Intel iTCO Watchdog Timer
+  KCONFIG:=CONFIG_ITCO_WDT \
+           CONFIG_ITCO_VENDOR_SUPPORT=y
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/iTCO_wdt.ko \
+         $(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/iTCO_vendor_support.ko
+  AUTOLOAD:=$(call AutoLoad,50,iTCO_vendor_support iTCO_wdt,1)
+endef
+
+define KernelPackage/itco-wdt/description
+  Kernel module for Intel iTCO Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,itco-wdt))
index 1a3f9150c203d4ea6c624fc0facccc06ac355eb8..70838df407605b25d747f5e15f58063edb621305 100644 (file)
@@ -201,7 +201,7 @@ CONFIG_INTEL_IDLE=y
 # CONFIG_IOMMU_DEBUG is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 # CONFIG_ITCO_VENDOR_SUPPORT is not set
-CONFIG_ITCO_WDT=y
+# CONFIG_ITCO_WDT is not set
 CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
 # CONFIG_KVM_DEBUG_FS is not set
 CONFIG_KVM_GUEST=y