kernel: add keyboard-imx module
authorLuka Perkov <luka@openwrt.org>
Fri, 25 Oct 2013 10:29:49 +0000 (10:29 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 25 Oct 2013 10:29:49 +0000 (10:29 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38537

package/kernel/linux/modules/input.mk

index 421a6b8fca7a69b444a088717eab5f7faccc683d..32adc1ecf49b34df42bf28b465924b575282e3d9 100644 (file)
@@ -159,7 +159,7 @@ define KernelPackage/input-matrixkmap
   KCONFIG:=CONFIG_INPUT_MATRIXKMAP
   DEPENDS:=@!LINUX_3_3
   FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
-  AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+  AUTOLOAD:=$(call AutoProbe,matrix-keymap)
   $(call AddDepends/input)
 endef
 
@@ -184,3 +184,21 @@ define KernelPackage/acpi-button/description
 endef
 
 $(eval $(call KernelPackage,acpi-button))
+
+
+define KernelPackage/keyboard-imx
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=IMX keypad support
+  DEPENDS:=@(TARGET_mxs||TARGET_imx6) +kmod-input-matrixkmap
+  KCONFIG:= \
+       CONFIG_KEYBOARD_IMX \
+       CONFIG_INPUT_KEYBOARD=y
+  FILES:=$(LINUX_DIR)/drivers/input/keyboard/imx_keypad.ko
+  AUTOLOAD:=$(call AutoProbe,imx_keypad)
+endef
+
+define KernelPackage/keyboard-imx/description
+ Enable support for IMX keypad port.
+endef
+
+$(eval $(call KernelPackage,keyboard-imx))