modules: add ahci-platform
authorJohn Crispin <john@openwrt.org>
Tue, 24 Feb 2015 12:00:16 +0000 (12:00 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 24 Feb 2015 12:00:16 +0000 (12:00 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 44524

package/kernel/linux/modules/block.mk

index 20588ac2767648bd493aa5cbb7a233fccfe0bfbf..159155e049bfe8a9d6353addd04fcf2b6390f02d 100644 (file)
@@ -56,6 +56,23 @@ endef
 $(eval $(call KernelPackage,ata-ahci))
 
 
+define KernelPackage/ata-ahci-platform
+  TITLE:=AHCI Serial ATA Platform support
+  KCONFIG:=CONFIG_SATA_AHCI_PLATFORM
+  FILES:= \
+    $(LINUX_DIR)/drivers/ata/ahci_platform.ko \
+    $(LINUX_DIR)/drivers/ata/libahci_platform.ko
+  AUTOLOAD:=$(call AutoLoad,40,libahci_platform ahci_platform,1)
+  $(call AddDepends/ata,+kmod-ata-ahci)
+endef
+
+define KernelPackage/ata-ahci-platform/description
+ Platform support for AHCI Serial ATA controllers
+endef
+
+$(eval $(call KernelPackage,ata-ahci-platform))
+
+
 define KernelPackage/ata-artop
   TITLE:=ARTOP 6210/6260 PATA support
   KCONFIG:=CONFIG_PATA_ARTOP