kernel: kmod-crypto-authenc: Add authencesn.ko
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 5 Aug 2022 22:03:13 +0000 (00:03 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 10 Aug 2022 19:36:17 +0000 (21:36 +0200)
The kernel configuration option CONFIG_CRYPTO_AUTHENC builds authenc.ko
and authencesn.ko, pack both kernel modules.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk

index ed4e51079ef0a6367054a9ce9665bfcf4c1c0107..72ed6ca2fdf665d787aa1a2e13a87849fbc5b4f3 100644 (file)
@@ -69,8 +69,10 @@ define KernelPackage/crypto-authenc
   TITLE:=Combined mode wrapper for IPsec
   DEPENDS:=+kmod-crypto-manager +kmod-crypto-null
   KCONFIG:=CONFIG_CRYPTO_AUTHENC
-  FILES:=$(LINUX_DIR)/crypto/authenc.ko
-  AUTOLOAD:=$(call AutoLoad,09,authenc)
+  FILES:= \
+       $(LINUX_DIR)/crypto/authenc.ko \
+       $(LINUX_DIR)/crypto/authencesn.ko
+  AUTOLOAD:=$(call AutoLoad,09,authenc authencesn)
   $(call AddDepends/crypto)
 endef