kernel: update to version 3.0.3
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 Aug 2011 12:54:12 +0000 (12:54 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 Aug 2011 12:54:12 +0000 (12:54 +0000)
SVN-Revision: 28043

include/kernel-version.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-3.0/0015-ssb-add-serial-flash-support.patch
target/linux/brcm47xx/patches-3.0/220-bcm5354.patch
target/linux/generic/patches-3.0/950-vm_exports.patch
target/linux/malta/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile

index 530fae283b367001d628990ef94fc1b2df5c6288..1b41d845824c89e519de4b053f17c1771d41b97a 100644 (file)
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.1)
-  LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
+ifeq ($(LINUX_VERSION),3.0.3)
+  LINUX_KERNEL_MD5SUM:=6a8af5f6733b3db970197e65b3db712c
 endif
 
 # disable the md5sum check for unknown kernel versions
index 167d9e4ecb469e29458e13687e68179328120378..ce5e8624c87f8cfc435ae847726f2b869466b26b 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 1e7762b4b2b3f2e18257333b05987c9351151342..e91c2a44f47c08c0816cfdac86f8b771c49f409c 100644 (file)
@@ -601,7 +601,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 +}
 --- a/drivers/ssb/driver_mipscore.c
 +++ b/drivers/ssb/driver_mipscore.c
-@@ -193,7 +193,13 @@ static void ssb_mips_flash_detect(struct
+@@ -203,7 +203,13 @@ static void ssb_mips_flash_detect(struct
        switch (bus->chipco.capabilities & SSB_CHIPCO_CAP_FLASHT) {
        case SSB_CHIPCO_FLASHT_STSER:
        case SSB_CHIPCO_FLASHT_ATSER:
index 7d7ca8e969bbb0ac03872a37570af38100081c31..6055e0a738f884a8f77872d41968bc6a4f0cfccc 100644 (file)
@@ -20,7 +20,7 @@
        switch (*plltype) {
 --- a/drivers/ssb/driver_mipscore.c
 +++ b/drivers/ssb/driver_mipscore.c
-@@ -234,6 +234,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
+@@ -241,6 +241,8 @@ u32 ssb_cpu_clock(struct ssb_mipscore *m
  
        if ((pll_type == SSB_PLLTYPE_5) || (bus->chip_id == 0x5365)) {
                rate = 200000000;
index e1b88a0bb1cdf4719fb804cd90786c025708c062..4be67a3a8e31618ab49ffeb89c2dbfc27cba42a3 100644 (file)
@@ -89,7 +89,7 @@
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -1245,6 +1245,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1246,6 +1246,7 @@ void unmap_kernel_range(unsigned long ad
        vunmap_page_range(addr, end);
        flush_tlb_kernel_range(addr, end);
  }
@@ -97,7 +97,7 @@
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1360,6 +1361,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1361,6 +1362,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
index 8f64714f306d4f4bea287fb2852930910ef83566..2c884dfa430bb120cfe13a49bbb8b7216ef64712 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index a8201f57eacb0091760d02076f2a9fb89fad6e67..54e0c37ff2e84e6be4917adc480e268ca248423b 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index ffd1b4489ad12a724dbe469a90202d0fe638ab75..b2cb3a25a5068ae433466e375bcbfb3ea82f31d2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 8f65693dba6d715c5b2547fd3f9463e90fe24825..0de828259b86bdfdb01228265ad6fc4c92d99f75 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index e697ba62dfc8f84fa3d9ee5c1ffc76e9a378285d..e758ea77eaa7a62be1f0877ab8215c8ff7990a84 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
 
index a91aac83b49e98ec2e9e057ea888d9ae8d308440..1f7b3fbcadcaf5cb3e38bb4d17dea661c9d93645 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk