ar71xx: build images for the TP-Link TL-WR703N v1 board
authorGabor Juhos <juhosg@openwrt.org>
Wed, 21 Sep 2011 11:47:56 +0000 (11:47 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 21 Sep 2011 11:47:56 +0000 (11:47 +0000)
Based on a patch by dongyuqi <729650915@qq.com>

SVN-Revision: 28279

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index c770d4915110de839924b3cabef1fa5d7eba43a3..ba55f3e0435bca719618da8ce73b01ad5b2566ba 100644 (file)
@@ -27,6 +27,17 @@ endef
 
 $(eval $(call Profile,TLMR3420V1))
 
+define Profile/TLWR703NV1
+       NAME:=TP-LINK TL-WR703N v1
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLWR703NV1/Description
+       Package set optimized for the TP-LINK TL-WR703N v1.
+endef
+
+$(eval $(call Profile,TLWR703NV1))
+
 define Profile/TLWA901NDV1
        NAME:=TP-LINK TL-WA901ND v1
        PACKAGES:=
index e4163b33e5705e9edd665993f435657929500699..b1e4c1c04d6114020aa97ff241bd094339fc42f3 100644 (file)
@@ -274,6 +274,20 @@ define Image/Build/TPLINK/initramfs
                -o $(call imgname,$(1),$(2))-uImage.bin
 endef
 
+define Image/Build/TPLINK-LZMA
+       $(call PatchKernelLzma,$(2),$(3))
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -B $(4) -N OpenWrt -V $(REVISION)\
+               -k $(KDIR)/vmlinux-$(2).bin.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(call factoryname,$(1),$(2))
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -B $(4) -N OpenWrt -V $(REVISION) -s \
+               -k $(KDIR)/vmlinux-$(2).bin.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(call sysupname,$(1),$(2))
+endef
+
 define Image/Build/CyberTAN
        $(call MkuImageGzip,$(2),$(3))
        $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR)/vmlinux-$(2).uImage \
@@ -640,6 +654,11 @@ define Image/Build/Profile/TLWR1043NDV1
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr1043nd-v1,$(tlwr1043nd_cmdline),TL-WR1043NDv1)
 endef
 
+tlwr703n_cmdline=board=TL-WR703N console=ttyATH0,115200
+define Image/Build/Profile/TLWR703NV1
+       $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK-LZMA,tl-wr703n-v1,$(tlwr703n_cmdline),TL-WR703Nv1)
+endef
+
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
 wndr3700v2_cmdline=board=WNDR3700v2 console=ttyS0,115200
@@ -722,6 +741,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR941NDV3,$(1))
        $(call Image/Build/Profile/TLWR941NDV4,$(1))
        $(call Image/Build/Profile/TLWR1043NDV1,$(1))
+       $(call Image/Build/Profile/TLWR703NV1,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
        $(call Image/Build/Profile/WNDR3700,$(1))