disable IMQ on 2.6.28 as well -- people should use IFB..
authorImre Kaloz <kaloz@openwrt.org>
Fri, 12 Dec 2008 11:11:28 +0000 (11:11 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 12 Dec 2008 11:11:28 +0000 (11:11 +0000)
SVN-Revision: 13612

package/kernel/modules/netfilter.mk

index 4177dc3eb4a068939aea31b18cc0874e98f628ae..e22707679318355a6fcadbe0ad8c7ce82655db85 100644 (file)
@@ -237,7 +237,7 @@ define KernelPackage/ipt-imq
        imq \
        $(IPT_IMQ-m) \
   ))
-  DEPENDS:= kmod-ipt-core @!LINUX_2_6_27
+  DEPENDS:= kmod-ipt-core @!LINUX_2_6_27 @!LINUX_2_6_28
 endef
 
 define KernelPackage/ipt-imq/description
@@ -358,7 +358,7 @@ $(eval $(call KernelPackage,ipt-extra))
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
-  DEPENDS:=+kmod-ipv6 @!LINUX_2_6_27
+  DEPENDS:=+kmod-ipv6 @!LINUX_2_6_27 @!LINUX_2_6_28
   KCONFIG:=CONFIG_IP6_NF_IPTABLES
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))