build: compress kernel debuginfo using zstd
authorMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 13 May 2020 18:33:46 +0000 (20:33 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Sun, 31 May 2020 09:03:31 +0000 (11:03 +0200)
zstd with its default settings (compression level -3) compresses better
than bzip2 -9 (which is the default setting), and is an order of magnitude
faster.

I made the following measurements for the most common compression tools
(all standard Debian Buster versions, default flags unless noted
otherwise), using the debug information of a large x86-64 kernel with
ALL_KMODS:

* kernel-debug.tar: 376M
* kernel-debug.tar.gz: 101M, compressed in ~12s
* kernel-debug.tar.bz2: 91M, compressed in ~15s
* kernel-debug.tar.xz: 57M, compressed in ~101s
* kernel-debug.tar.zst: 86M, compressed in ~1s

With zstd, there is still some room for improvement by increasing the
compression, but the slight increase in compression ratio
(22.83% -> 19.46%) does not justify the significant increase in
compression time (about 5 times on my machine) in my opinion.

Note that multithreaded compression (-T argument) does not affect
reproducibility with zstd.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
include/kernel-build.mk

index c371e78ab9b0b63bdd4de77cfa426ce0d3afbf9b..32c91a5b8359eb49bccbc4dd911159f9871b9ac1 100644 (file)
@@ -70,7 +70,7 @@ ifdef CONFIG_COLLECT_KERNEL_DEBUG
        $(FIND) $(KERNEL_BUILD_DIR)/debug -type f | $(XARGS) $(KERNEL_CROSS)strip --only-keep-debug
        $(TAR) c -C $(KERNEL_BUILD_DIR) debug \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               | bzip2 -c -9 > $(BIN_DIR)/kernel-debug.tar.bz2
+               | zstd -T0 -f -o $(BIN_DIR)/kernel-debug.tar.zst
   endef
 endif