ar71xx: add profile and build firmware image for the Oolite v1 board
authorGabor Juhos <juhosg@openwrt.org>
Thu, 27 Mar 2014 06:36:57 +0000 (06:36 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 27 Mar 2014 06:36:57 +0000 (06:36 +0000)
Patch-by: Lars Bøgild Thomsen <lth@cow.dk>
Patchwork: http://patchwork.openwrt.org/patch/4922/
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 40036

target/linux/ar71xx/generic/profiles/oolite.mk [new file with mode: 0644]
target/linux/ar71xx/image/Makefile

diff --git a/target/linux/ar71xx/generic/profiles/oolite.mk b/target/linux/ar71xx/generic/profiles/oolite.mk
new file mode 100644 (file)
index 0000000..448f08d
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OOLITE
+       NAME:=OOLITE
+       PACKAGES:=kmod-usb-core kmod-usb2  kmod-ledtrig-usbdev
+endef
+
+
+define Profile/OOLITE/Description
+       Package set optimized for the OOLITE.
+endef
+$(eval $(call Profile,OOLITE))
+
index b2b17066f4d9a96ea0b84b4ca1ed1adb7e3fa750..09bcb2c368afaa3a9d0e8b0acb5d9849436a7208 100644 (file)
@@ -1054,6 +1054,8 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWDR4310V1,tl-wdr4310-v1,TL-WDR4
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,TLWDR4900V2,tl-wdr4900-v2,TL-WDR4900-v2,ttyS0,115200,0x49000002,1,8Mlzma))
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,MW4530RV1,mw4530r-v1,TL-WDR4300,ttyS0,115200,0x45300001,1,8Mlzma))
 
+$(eval $(call SingleProfile,TPLINK-LZMA,64kraw,OOLITE,oolite,GS-OOLITE,ttyATH0,115200,0x3C000101,1,16Mlzma))
+
 $(eval $(call SingleProfile,UAPPRO,64k,UAPPRO,ubnt-uap-pro,UAP-PRO,ttyS0,115200,BZ,BZ,ar934x))
 
 $(eval $(call SingleProfile,UBDEV,64kraw,UBDEV01,ubdev01,UBNT-UF,ttyS0,115200,XM,XM,ar7240))