rules: fix COMMITCOUNT logic
authorPaul Spooren <mail@aparcar.org>
Wed, 27 Jan 2021 03:16:36 +0000 (17:16 -1000)
committerPaul Spooren <mail@aparcar.org>
Wed, 27 Jan 2021 03:29:49 +0000 (17:29 -1000)
The newly added $(COMMITCOUNT) variable was wrongly increased by plus
one. The addition should have been only added to $(AUTORELEASE) as
OpenWrt traditionally starts counting at one rather than zero.

$(AUTORELEASE) counts the commits since the last bump, which is zero on
the version bump commit itself.

This commit increases $(AUTORELEASE) by one while leaving $(COMMITCOUNT)
as is.

The base-files package is the only package using $(COMMITCOUNT) so far
and requires a pseudo commit to keep the PKG_RELEASE correct. A non
functional change (Copyright bump) is done in the next commit.

Signed-off-by: Paul Spooren <mail@aparcar.org>
rules.mk

index cf4aa30d213f09e586a937147fec6c403481b1fe..b1b69eabf9ea735d9f1c41446e80c6a4a6c4308a 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -421,7 +421,7 @@ $(shell \
     if [ -n "$$last_bump" ]; then \
       echo -n $$(($$(git rev-list --count "$$last_bump..HEAD" .) + 1)); \
     else \
-      echo -n $$(($$(git rev-list --count HEAD .) + 1)); \
+      git rev-list --count HEAD .; \
     fi; \
   else \
     secs="$$(($(SOURCE_DATE_EPOCH) % 86400))"; \