kernel: kmod-input-polldev: Depend on kernel 5.10
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Aug 2022 13:26:21 +0000 (15:26 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 10 Aug 2022 19:36:17 +0000 (21:36 +0200)
The input-polldev.ko kernel module was removed from kernel 5.11. The
normal input implementation now supports polling.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/input.mk

index 7f042e85359123ddb315a3b3b3c0e881bdb1a605..b0ab3360cc9ae4c5035d6a8cc9b9ed9a54bafbc9 100644 (file)
@@ -92,7 +92,7 @@ $(eval $(call KernelPackage,input-gpio-keys))
 define KernelPackage/input-gpio-keys-polled
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Polled GPIO key support
-  DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
+  DEPENDS:=@GPIO_SUPPORT +LINUX_5_10:kmod-input-polldev
   KCONFIG:= \
        CONFIG_KEYBOARD_GPIO_POLLED \
        CONFIG_INPUT_KEYBOARD=y
@@ -145,7 +145,7 @@ $(eval $(call KernelPackage,input-joydev))
 define KernelPackage/input-polldev
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Polled Input device support
-  DEPENDS:=+kmod-input-core
+  DEPENDS:=+kmod-input-core @LINUX_5_10
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
 endef