update to kernel 3.0
authorFlorian Fainelli <florian@openwrt.org>
Fri, 5 Aug 2011 13:48:42 +0000 (13:48 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 5 Aug 2011 13:48:42 +0000 (13:48 +0000)
SVN-Revision: 27912

target/linux/malta/Makefile
target/linux/malta/le/config-default
target/linux/malta/patches-3.0/001-mips-malta-fix-crash-smp-kernel-on-non-cmp-systems.patch [new file with mode: 0644]

index dcddd2cad83ea0348d62aa44d94782eece36f309..4fbdf49d1102a998d515284e1e14fcbd2844feaa 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=3.0
 
 include $(INCLUDE_DIR)/target.mk
 
index 4538de78994082b7d2e9a4f82cb82bba30d961ee..c0dc06368b3d44086dbfb6ccc78618ef1a6688d7 100644 (file)
@@ -10,6 +10,7 @@ CONFIG_ARCH_SUPPORTS_OPROFILE=y
 # CONFIG_ATH79 is not set
 CONFIG_AX88796=m
 # CONFIG_AX88796_93CX6 is not set
+CONFIG_BCMA_POSSIBLE=y
 # CONFIG_BE2NET is not set
 # CONFIG_BLK_DEV_DM is not set
 # CONFIG_BLK_DEV_INITRD is not set
@@ -28,6 +29,7 @@ CONFIG_CC_OPTIMIZE_FOR_SIZE=y
 CONFIG_CEVT_R4K=y
 CONFIG_CEVT_R4K_LIB=y
 CONFIG_CICADA_PHY=m
+CONFIG_CLKSRC_I8253=y
 # CONFIG_CLS_U32_MARK is not set
 # CONFIG_CLS_U32_PERF is not set
 CONFIG_CONSOLE_TRANSLATIONS=y
@@ -86,8 +88,6 @@ CONFIG_GENERIC_ATOMIC64=y
 CONFIG_GENERIC_CLOCKEVENTS=y
 CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 CONFIG_GENERIC_CMOS_UPDATE=y
-CONFIG_GENERIC_FIND_LAST_BIT=y
-CONFIG_GENERIC_FIND_NEXT_BIT=y
 CONFIG_GENERIC_IRQ_SHOW=y
 CONFIG_GENERIC_ISA_DMA=y
 # CONFIG_HAMRADIO is not set
@@ -128,7 +128,6 @@ CONFIG_ICPLUS_PHY=m
 CONFIG_IMAGE_CMDLINE_HACK=y
 CONFIG_INET_DIAG=y
 CONFIG_INET_TCP_DIAG=y
-CONFIG_INOTIFY_USER=y
 CONFIG_INPUT=y
 # CONFIG_INPUT_MISC is not set
 CONFIG_INPUT_MOUSEDEV=y
@@ -147,6 +146,8 @@ CONFIG_JFFS2_FS_POSIX_ACL=y
 CONFIG_JFFS2_FS_SECURITY=y
 # CONFIG_JFFS2_SUMMARY is not set
 CONFIG_KALLSYMS=y
+CONFIG_KERNEL_GZIP=y
+# CONFIG_LANTIQ is not set
 # CONFIG_LEDS_TRIGGER_TIMER is not set
 CONFIG_LEGACY_PTYS=y
 CONFIG_LEGACY_PTY_COUNT=256
diff --git a/target/linux/malta/patches-3.0/001-mips-malta-fix-crash-smp-kernel-on-non-cmp-systems.patch b/target/linux/malta/patches-3.0/001-mips-malta-fix-crash-smp-kernel-on-non-cmp-systems.patch
new file mode 100644 (file)
index 0000000..03866df
--- /dev/null
@@ -0,0 +1,166 @@
+From d9a056919c4fa46cd9e094f969032bd4e15bffef Mon Sep 17 00:00:00 2001
+From: Ralf Baechle <ralf@linux-mips.org>
+Date: Sat, 28 May 2011 15:27:59 +0100
+Subject: [PATCH] MIPS: Malta: Fix crash SMP kernel on non-CMP systems.
+
+Since 6be63bbbdab66b9185dc6f67c8b1bacb6f37f946 (lmo) rsp.
+af3a1f6f4813907e143f87030cde67a9971db533 (kernel.org) the Malta code does
+no longer probe for presence of GCMP if CMP is not configured.  This means
+that the variable gcmp_present well be left at its default value of -1
+which normally is meant to indicate that GCMP has not yet been mmapped.
+This non-zero value is now interpreted as GCMP being present resulting
+in a write attempt to a GCMP register resulting in a crash.
+
+Reported and a build fix on top of my fix by Rob Landley <rob@landley.net>.
+
+Reported-by: Rob Landley <rob@landley.net>
+Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
+Patchwork: https://patchwork.linux-mips.org/patch/2413/
+(cherry picked from commit c3ddf592134eaab38d051b2e7b23e81201ae423a)
+---
+ arch/mips/include/asm/smp-ops.h          |   41 +++++++++++++++++++++++++++--
+ arch/mips/mipssim/sim_setup.c            |   17 ++++++------
+ arch/mips/mti-malta/malta-init.c         |   14 +++++-----
+ arch/mips/pmc-sierra/msp71xx/msp_setup.c |    8 ++---
+ 4 files changed, 56 insertions(+), 24 deletions(-)
+
+diff --git a/arch/mips/include/asm/smp-ops.h b/arch/mips/include/asm/smp-ops.h
+index 9e09af3..48b03ff 100644
+--- a/arch/mips/include/asm/smp-ops.h
++++ b/arch/mips/include/asm/smp-ops.h
+@@ -56,8 +56,43 @@ static inline void register_smp_ops(struct plat_smp_ops *ops)
+ #endif /* !CONFIG_SMP */
+-extern struct plat_smp_ops up_smp_ops;
+-extern struct plat_smp_ops cmp_smp_ops;
+-extern struct plat_smp_ops vsmp_smp_ops;
++static inline int register_up_smp_ops(void)
++{
++#ifdef CONFIG_SMP_UP
++      extern struct plat_smp_ops up_smp_ops;
++
++      register_smp_ops(&up_smp_ops);
++
++      return 0;
++#else
++      return -ENODEV;
++#endif
++}
++
++static inline int register_cmp_smp_ops(void)
++{
++#ifdef CONFIG_MIPS_CMP
++      extern struct plat_smp_ops cmp_smp_ops;
++
++      register_smp_ops(&cmp_smp_ops);
++
++      return 0;
++#else
++      return -ENODEV;
++#endif
++}
++
++static inline int register_vsmp_smp_ops(void)
++{
++#ifdef CONFIG_MIPS_MT_SMP
++      extern struct plat_smp_ops vsmp_smp_ops;
++
++      register_smp_ops(&vsmp_smp_ops);
++
++      return 0;
++#else
++      return -ENODEV;
++#endif
++}
+ #endif /* __ASM_SMP_OPS_H */
+diff --git a/arch/mips/mipssim/sim_setup.c b/arch/mips/mipssim/sim_setup.c
+index 55f22a3..1970069 100644
+--- a/arch/mips/mipssim/sim_setup.c
++++ b/arch/mips/mipssim/sim_setup.c
+@@ -59,18 +59,17 @@ void __init prom_init(void)
+       prom_meminit();
+-#ifdef CONFIG_MIPS_MT_SMP
+-      if (cpu_has_mipsmt)
+-              register_smp_ops(&vsmp_smp_ops);
+-      else
+-              register_smp_ops(&up_smp_ops);
+-#endif
++      if (cpu_has_mipsmt) {
++              if (!register_vsmp_smp_ops())
++                      return;
++
+ #ifdef CONFIG_MIPS_MT_SMTC
+-      if (cpu_has_mipsmt)
+               register_smp_ops(&ssmtc_smp_ops);
+-      else
+-              register_smp_ops(&up_smp_ops);
++                      return;
+ #endif
++      }
++
++      register_up_smp_ops();
+ }
+ static void __init serial_init(void)
+diff --git a/arch/mips/mti-malta/malta-init.c b/arch/mips/mti-malta/malta-init.c
+index 31180c3..4b988b9 100644
+--- a/arch/mips/mti-malta/malta-init.c
++++ b/arch/mips/mti-malta/malta-init.c
+@@ -28,6 +28,7 @@
+ #include <asm/io.h>
+ #include <asm/system.h>
+ #include <asm/cacheflush.h>
++#include <asm/smp-ops.h>
+ #include <asm/traps.h>
+ #include <asm/gcmpregs.h>
+@@ -358,15 +359,14 @@ void __init prom_init(void)
+ #ifdef CONFIG_SERIAL_8250_CONSOLE
+       console_config();
+ #endif
+-#ifdef CONFIG_MIPS_CMP
+       /* Early detection of CMP support */
+       if (gcmp_probe(GCMP_BASE_ADDR, GCMP_ADDRSPACE_SZ))
+-              register_smp_ops(&cmp_smp_ops);
+-      else
+-#endif
+-#ifdef CONFIG_MIPS_MT_SMP
+-              register_smp_ops(&vsmp_smp_ops);
+-#endif
++              if (!register_cmp_smp_ops())
++                      return;
++
++      if (!register_vsmp_smp_ops())
++              return;
++
+ #ifdef CONFIG_MIPS_MT_SMTC
+       register_smp_ops(&msmtc_smp_ops);
+ #endif
+diff --git a/arch/mips/pmc-sierra/msp71xx/msp_setup.c b/arch/mips/pmc-sierra/msp71xx/msp_setup.c
+index 2413ea6..0abfbe0 100644
+--- a/arch/mips/pmc-sierra/msp71xx/msp_setup.c
++++ b/arch/mips/pmc-sierra/msp71xx/msp_setup.c
+@@ -228,13 +228,11 @@ void __init prom_init(void)
+        */
+       msp_serial_setup();
+-#ifdef CONFIG_MIPS_MT_SMP
+-      register_smp_ops(&vsmp_smp_ops);
+-#endif
+-
++      if (register_vsmp_smp_ops()) {
+ #ifdef CONFIG_MIPS_MT_SMTC
+-      register_smp_ops(&msp_smtc_smp_ops);
++              register_smp_ops(&msp_smtc_smp_ops);
+ #endif
++      }
+ #ifdef CONFIG_PMCTWILED
+       /*
+-- 
+1.7.3.4
+