rules.mk: add option to download files into a subdirectory
authorMichael Pratt <mcpratt@pm.me>
Wed, 3 Aug 2022 17:01:51 +0000 (13:01 -0400)
committerMichael Pratt <mcpratt@pm.me>
Thu, 22 Sep 2022 20:48:35 +0000 (16:48 -0400)
Some packages download a single raw file or set of raw files
instead of an archive.

The filenames of these download files have names and version numbers
that do not directly correspond to the name and version of the package
as it is defined in its Makefile.

To better organize downloaded files, this adds the option of
creating a subdirectory in the download directory for these files
that can be named with package specific variables.

DL_DIR is now a recursively expanded variable
since the value now depends on whether DL_SUBDIR is defined.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
rules.mk

index c893f61b0f702ba8696a6132567e6f6c1f6ce763..2072658e782a5c0918d8b453820082b24c67747f 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -109,7 +109,7 @@ $(foreach t,$(DEFAULT_SUBDIR_TARGETS) $(1),
 )
 endef
 
-DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
+DL_DIR=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)$(if $(DL_SUBDIR),/$(DL_SUBDIR))
 OUTPUT_DIR:=$(if $(call qstrip,$(CONFIG_BINARY_FOLDER)),$(call qstrip,$(CONFIG_BINARY_FOLDER)),$(TOPDIR)/bin)
 BIN_DIR:=$(OUTPUT_DIR)/targets/$(BOARD)/$(SUBTARGET)
 INCLUDE_DIR:=$(TOPDIR)/include