rules: drop -Wno-error additional flags from default TARGET_CFLAGS
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 17 Jul 2022 11:26:14 +0000 (13:26 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 26 Dec 2022 11:59:18 +0000 (12:59 +0100)
We currently enable -Wno-error=unused-but-set-variable and
-Wno-error=unused-result by default on every compile package.

While this is (relatively) unharmful, we should follow other project
direction and starts enforcing good code quality. For example the linux
kernel recently started to enforce Wall by default and clean code is
mandatory for inclusion.

Drop for good these flags and and make it mandatory to correctly handle
return values at least with a warning log if they are not strictly error
condition.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
rules.mk

index e17852e02177e3b6b01cd9aff655a16381181d73..d53f673d425ec3b9a081d6736c600bfc3a504954 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -184,7 +184,7 @@ ifndef DUMP
     -include $(TOOLCHAIN_DIR)/info.mk
     export GCC_HONOUR_COPTS:=0
     TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-openwrt-linux$(if $(TARGET_SUFFIX),-$(TARGET_SUFFIX))-)
-    TARGET_CFLAGS+= -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result
+    TARGET_CFLAGS+= -fhonour-copts
     TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/usr/include
     ifeq ($(CONFIG_USE_MUSL),y)
       TARGET_CPPFLAGS+= -I$(TOOLCHAIN_DIR)/include/fortify