kernel: bump 4.14 to 4.14.139
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 16 Aug 2019 11:24:56 +0000 (13:24 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 27 Aug 2019 08:32:44 +0000 (10:32 +0200)
Refreshed all patches.

Also add a missing symbol for x86 which got used now in this bump.
- ISCSI_IBFT

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/x86/64/config-4.14
target/linux/x86/generic/config-4.14
target/linux/x86/geode/config-4.14
target/linux/x86/legacy/config-4.14

index c03c8a369ae04c11f28ed6bb8a2807c080515e09..354b493236ad4df6c6b2c14135d4e0196ff5a401 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .189
-LINUX_VERSION-4.14 = .138
+LINUX_VERSION-4.14 = .139
 LINUX_VERSION-4.19 = .66
 
 LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
-LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
+LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
 LINUX_KERNEL_HASH-4.19.66 = c981abe15c4b9496cdadb04e4f4afb88b3a78f31ced8d07684ee9c58b3fadb64
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 2a20058ed37a7d178db20323350683ab630f81b7..aedefb32b4f2cf1ed6dbef82eaf9c6c4fd6ca7b0 100644 (file)
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2774,6 +2774,8 @@ static const struct file_operations proc
+@@ -2783,6 +2783,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {
index 85ddd6309b0d87135dbf252bbd7683a91bd4d0c0..b9777c0f72dd6dc05d3c825c1f4ae6ca7726a17d 100644 (file)
@@ -274,6 +274,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
 # CONFIG_IOMMU_DEBUG is not set
 CONFIG_IOSF_MBI=y
 # CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
 # CONFIG_KVM_DEBUG_FS is not set
index 92380f526db504bbc3bceee93c53862e1cc9bf68..1e31e117dd0fde60d5d9808db1023081070e0dd5 100644 (file)
@@ -214,6 +214,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
 CONFIG_ISA=y
 CONFIG_ISAPNP=y
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_ISO9660_FS=y
 # CONFIG_JOLIET is not set
index f75891cee77374e507b5117618087461b2382be2..796aba7cd2fbff2b546379103cd60ce57cb948ac 100644 (file)
@@ -73,6 +73,7 @@ CONFIG_IOSF_MBI=y
 CONFIG_ISA=y
 # CONFIG_ISAPNP is not set
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 # CONFIG_LANCE is not set
 CONFIG_LEDS_GPIO=y
index dab36d39fce45abe79de8705e4f56da1c6c4ebbc..6fa2d083ab3e4f55bd145acbc89027182f99c5a5 100644 (file)
@@ -133,6 +133,7 @@ CONFIG_IOSF_MBI=y
 CONFIG_ISA=y
 CONFIG_ISAPNP=y
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_ISO9660_FS=y
 # CONFIG_JOLIET is not set