kernel: Remove crypto/ablk_helper.ko on kernel 4.19
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Nov 2018 19:36:35 +0000 (20:36 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 15 Dec 2018 13:28:49 +0000 (14:28 +0100)
This module was removed in kernel 4.17, all users are refactored to not
need this any more.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk

index 4892f1493264262451100b33cf784e401c70f15b..1fc4ffb7ed120bded4c3d3beb34718854683686e 100644 (file)
@@ -500,10 +500,10 @@ ifndef CONFIG_TARGET_x86_64
        $(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko \
        $(LINUX_DIR)/arch/x86/crypto/serpent-sse2-i586.ko \
        $(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
-       $(LINUX_DIR)/crypto/ablk_helper.ko \
+       $(LINUX_DIR)/crypto/ablk_helper.ko@lt4.17 \
        $(LINUX_DIR)/crypto/cryptd.ko \
        $(LINUX_DIR)/crypto/lrw.ko
-    AUTOLOAD+= $(call AutoLoad,10,lrw cryptd ablk_helper glue_helper \
+    AUTOLOAD+= $(call AutoLoad,10,lrw cryptd glue_helper \
        serpent-sse2-i586 twofish-i586 blowfish_generic)
   endef
 endif
@@ -522,8 +522,8 @@ define KernelPackage/crypto-misc/x86/64
        $(LINUX_DIR)/arch/x86/crypto/serpent-avx-x86_64.ko \
        $(LINUX_DIR)/arch/x86/crypto/camellia-aesni-avx2.ko \
        $(LINUX_DIR)/arch/x86/crypto/serpent-avx2.ko \
-       $(LINUX_DIR)/crypto/ablk_helper.ko
-  AUTOLOAD+= $(call AutoLoad,10,ablk_helper camellia-x86_64 \
+       $(LINUX_DIR)/crypto/ablk_helper.ko@lt4.17
+  AUTOLOAD+= $(call AutoLoad,10,camellia-x86_64 \
        camellia-aesni-avx-x86_64 camellia-aesni-avx2 cast5-avx-x86_64 \
        cast6-avx-x86_64 twofish-x86_64 twofish-x86_64-3way \
        twofish-avx-x86_64 blowfish-x86_64 serpent-avx-x86_64 serpent-avx2)