linux/modules: add support for Asix ax88179 USB-Gigabit Ethernet adapters
authorJohn Crispin <john@openwrt.org>
Wed, 4 Feb 2015 06:10:57 +0000 (06:10 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 4 Feb 2015 06:10:57 +0000 (06:10 +0000)
requested and tested by forum user OWonPi
https://forum.openwrt.org/viewtopic.php?id=55495

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 44256

package/kernel/linux/modules/usb.mk

index 7498bcb014dfedc415fe4ab0b778a44c58851551..431c7baa2c3b24b8228750c0127a2a4fa5132b80 100644 (file)
@@ -1027,6 +1027,23 @@ endef
 $(eval $(call KernelPackage,usb-net-asix))
 
 
+define KernelPackage/usb-net-asix-ax88179
+  TITLE:=Kernel module for USB-to-Gigabit-Ethernet Asix convertors
+  DEPENDS:=+kmod-libphy
+  KCONFIG:=CONFIG_USB_NET_AX88179_178A
+  FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/ax88179_178a.ko
+  AUTOLOAD:=$(call AutoProbe,ax88179_178a)
+  $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-asix-ax88179/description
+ Kernel module for USB-to-Ethernet ASIX AX88179 based USB 3.0/2.0
+ to Gigabit Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,usb-net-asix-ax88179))
+
+
 define KernelPackage/usb-net-hso
   TITLE:=Kernel module for Option USB High Speed Mobile Devices
   KCONFIG:=CONFIG_USB_HSO