tools/make-ext4fs: Fix build on MacOSX
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 28 Apr 2018 16:20:20 +0000 (18:20 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 28 Apr 2018 22:57:07 +0000 (00:57 +0200)
MacOSX does not support "-Wl,-Bstatic" so do not force the static
linking.
We only copy the static libz library into the staging libraries
directories, the linker will anyway only find the static version and
link against that on all systems.

Fixes: 8dcd941d8b9 ("tools/zlib: move zlib build to tools")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
tools/make-ext4fs/Makefile

index 97f9e6369c0e37442e14d00bb1b28d4f1c648369..f67ab6e5b58f9ea4e1ea0dfba34293086ebd0e4d 100644 (file)
@@ -17,8 +17,6 @@ PKG_MIRROR_HASH:=d7ccd5e426b1d15331ff000a37dc15161f6eef594453e970fd584fcde5a2507
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_MAKE_FLAGS += STATIC=1
-
 define Host/Install
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/make_ext4fs $(STAGING_DIR_HOST)/bin/
 endef
 define Host/Install
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/make_ext4fs $(STAGING_DIR_HOST)/bin/
 endef