uhttpd: fix time_t type mismatch on 32bit systems
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 25 Jan 2015 17:59:08 +0000 (17:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 25 Jan 2015 17:59:08 +0000 (17:59 +0000)
The previous update introducing LFS support unconditionally changed the
sprintf() pattern used to print the file modification time to use PRIx64.

Explicitely convert the st_mtime member of the stat struct to uint64_t in
order to avoid type mismatch errors when building for non-64bit targets.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44138

package/network/services/uhttpd/Makefile

index 9cd28e25d052fb5a481e065eb22291c2dd0a88bb..1bb0084392fefb561bc83f0d67f66f6bbf29babb 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_VERSION:=2015-01-25
+PKG_VERSION:=2015-01-25.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7352ec423fb99a7970b0765287503abee05a56cd
+PKG_SOURCE_VERSION:=d404cd06b657cdcd97555362abec7966e339fd6d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 PKG_LICENSE:=ISC