mac80211: Update to version 5.3.6
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 11 Oct 2019 21:15:57 +0000 (23:15 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 19 Oct 2019 10:35:55 +0000 (12:35 +0200)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/mac80211/Makefile
package/kernel/mac80211/patches/ath/558-ath9k-dynack-introduce-ath_dynack_set_timeout-routin.patch
package/kernel/mac80211/patches/ath/559-ath9k-dynack-properly-set-last-timeout-timestamp-in-.patch
package/kernel/mac80211/patches/ath/560-ath9k-dynack-set-max-timeout-according-to-channel-wi.patch
package/kernel/mac80211/patches/ath/561-ath9k-dynack-set-ackto-to-max-timeout-in-ath_dynack_.patch
package/kernel/mac80211/patches/rt2x00/010-rt2x00-clear-IV-s-on-start-to-fix-AP-mode-regression.patch [deleted file]
package/kernel/mac80211/patches/rt2x00/011-rt2x00-clear-up-IV-s-on-key-removal.patch [deleted file]
package/kernel/mac80211/patches/rt2x00/016-rt2x00-revert-rt2800-enable-TX_PIN_CFG_LNA_PE_-bits-per-band.patch [deleted file]
package/kernel/mac80211/patches/subsys/210-ap_scan.patch
package/kernel/mac80211/patches/subsys/350-cfg80211-add-local-BSS-receive-time-to-survey-inform.patch
package/kernel/mac80211/patches/subsys/500-mac80211_configure_antenna_gain.patch

index 3cc14944fed9bcbd5956720c62293a58798a0f46..9f72cb0f63581bac223615b362cf32dc1fc7f19d 100644 (file)
@@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mac80211
 
-PKG_VERSION:=5.3-rc4-1
+PKG_VERSION:=5.3.6-1
 PKG_RELEASE:=1
-PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.3-rc4/
-PKG_HASH:=b159557f1e9e3e88ee2edf60ee786cd9ffd477e386306ea249c4e9085695b932
+PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.3.6/
+PKG_HASH:=16ded706945999543a73e2349d36b8003eeb2b097970ea1ad80344b9f56393a3
 
 PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/backports-$(PKG_VERSION)
index e13a15026e829b01ddc4c1a8eafa39fd852952ef..d765f88559ccf96059999c9e1260a4c1fa7e7a45 100644 (file)
@@ -12,15 +12,12 @@ Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
  drivers/net/wireless/ath/ath9k/dynack.c | 37 ++++++++++++++-----------
  1 file changed, 21 insertions(+), 16 deletions(-)
 
-diff --git a/drivers/net/wireless/ath/ath9k/dynack.c b/drivers/net/wireless/ath/ath9k/dynack.c
-index f112fa5b2eac..38dbe25919f7 100644
 --- a/drivers/net/wireless/ath/ath9k/dynack.c
 +++ b/drivers/net/wireless/ath/ath9k/dynack.c
-@@ -78,6 +78,24 @@ static inline bool ath_dynack_bssidmask(struct ath_hw *ah, const u8 *mac)
-       return true;
+@@ -79,6 +79,24 @@ static inline bool ath_dynack_bssidmask(
  }
  
-+/**
+ /**
 + * ath_dynack_set_timeout - configure timeouts/slottime registers
 + * @ah: ath hw
 + * @to: timeout value
@@ -38,10 +35,11 @@ index f112fa5b2eac..38dbe25919f7 100644
 +      ath9k_hw_set_cts_timeout(ah, to);
 +}
 +
- /**
++/**
   * ath_dynack_compute_ackto - compute ACK timeout as the maximum STA timeout
   * @ah: ath hw
-@@ -86,7 +104,6 @@ static inline bool ath_dynack_bssidmask(struct ath_hw *ah, const u8 *mac)
+  *
+@@ -86,7 +104,6 @@ static inline bool ath_dynack_bssidmask(
   */
  static void ath_dynack_compute_ackto(struct ath_hw *ah)
  {
@@ -49,7 +47,7 @@ index f112fa5b2eac..38dbe25919f7 100644
        struct ath_dynack *da = &ah->dynack;
        struct ath_node *an;
        int to = 0;
-@@ -96,15 +113,8 @@ static void ath_dynack_compute_ackto(struct ath_hw *ah)
+@@ -96,15 +113,8 @@ static void ath_dynack_compute_ackto(str
                        to = an->ackto;
  
        if (to && da->ackto != to) {
@@ -66,7 +64,7 @@ index f112fa5b2eac..38dbe25919f7 100644
        }
  }
  
-@@ -198,10 +208,7 @@ void ath_dynack_sample_tx_ts(struct ath_hw *ah, struct sk_buff *skb,
+@@ -198,10 +208,7 @@ void ath_dynack_sample_tx_ts(struct ath_
                    ieee80211_is_assoc_resp(hdr->frame_control) ||
                    ieee80211_is_auth(hdr->frame_control)) {
                        ath_dbg(common, DYNACK, "late ack\n");
@@ -89,6 +87,3 @@ index f112fa5b2eac..38dbe25919f7 100644
  }
  EXPORT_SYMBOL(ath_dynack_reset);
  
--- 
-2.17.1
-
index 9504af1419067a059da511171e3bfd4caaba1a18..5a2aac27823a6076b7b8a5d5df3642161679baa1 100644 (file)
@@ -14,8 +14,6 @@ Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
  drivers/net/wireless/ath/ath9k/dynack.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/drivers/net/wireless/ath/ath9k/dynack.c b/drivers/net/wireless/ath/ath9k/dynack.c
-index 38dbe25919f7..398ea872751f 100644
 --- a/drivers/net/wireless/ath/ath9k/dynack.c
 +++ b/drivers/net/wireless/ath/ath9k/dynack.c
 @@ -338,7 +338,7 @@ void ath_dynack_reset(struct ath_hw *ah)
@@ -27,6 +25,3 @@ index 38dbe25919f7..398ea872751f 100644
        da->ackto = ackto;
  
        da->st_rbf.t_rb = 0;
--- 
-2.17.1
-
index f40289cca4abbd035270cc98bc498ddb0351fa29..876b113aba2e2b37ebb32ff67b8842c5ea9d8707 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
  drivers/net/wireless/ath/ath9k/dynack.c | 38 +++++++++++++++++++------
  1 file changed, 30 insertions(+), 8 deletions(-)
 
-diff --git a/drivers/net/wireless/ath/ath9k/dynack.c b/drivers/net/wireless/ath/ath9k/dynack.c
-index 398ea872751f..fe9181533de3 100644
 --- a/drivers/net/wireless/ath/ath9k/dynack.c
 +++ b/drivers/net/wireless/ath/ath9k/dynack.c
-@@ -20,11 +20,30 @@
+@@ -20,12 +20,31 @@
  
  #define COMPUTE_TO            (5 * HZ)
  #define LATEACK_DELAY         (10 * HZ)
@@ -25,7 +23,7 @@ index 398ea872751f..fe9181533de3 100644
  #define EWMA_LEVEL            96
  #define EWMA_DIV              128
  
-+/**
+ /**
 + * ath_dynack_get_max_to - set max timeout according to channel width
 + * @ah: ath hw
 + *
@@ -46,10 +44,11 @@ index 398ea872751f..fe9181533de3 100644
 +      return 600;
 +}
 +
- /**
++/**
   * ath_dynack_ewma - EWMA (Exponentially Weighted Moving Average) calculation
   *
-@@ -126,15 +145,16 @@ static void ath_dynack_compute_ackto(struct ath_hw *ah)
+  */
+@@ -126,15 +145,16 @@ static void ath_dynack_compute_ackto(str
   */
  static void ath_dynack_compute_to(struct ath_hw *ah)
  {
@@ -70,7 +69,7 @@ index 398ea872751f..fe9181533de3 100644
        while (da->st_rbf.h_rb != da->st_rbf.t_rb &&
               da->ack_rbf.h_rb != da->ack_rbf.t_rb) {
                ack_ts = da->ack_rbf.tstamp[da->ack_rbf.h_rb];
-@@ -150,7 +170,7 @@ static void ath_dynack_compute_to(struct ath_hw *ah)
+@@ -150,7 +170,7 @@ static void ath_dynack_compute_to(struct
                if (ack_ts > st_ts->tstamp + st_ts->dur) {
                        ackto = ack_ts - st_ts->tstamp - st_ts->dur;
  
@@ -79,7 +78,7 @@ index 398ea872751f..fe9181533de3 100644
                                sta = ieee80211_find_sta_by_ifaddr(ah->hw, dst,
                                                                   src);
                                if (sta) {
-@@ -207,8 +227,10 @@ void ath_dynack_sample_tx_ts(struct ath_hw *ah, struct sk_buff *skb,
+@@ -207,8 +227,10 @@ void ath_dynack_sample_tx_ts(struct ath_
                if (ieee80211_is_assoc_req(hdr->frame_control) ||
                    ieee80211_is_assoc_resp(hdr->frame_control) ||
                    ieee80211_is_auth(hdr->frame_control)) {
@@ -91,6 +90,3 @@ index 398ea872751f..fe9181533de3 100644
                        if (sta) {
                                struct ath_node *an;
  
--- 
-2.17.1
-
index 5b75096e195b537aba7eb5a0c2f7a33a7e452d78..6495bf01b00b831522c186cbcfaf43a797dc6ee1 100644 (file)
@@ -16,8 +16,6 @@ Signed-off-by: Lorenzo Bianconi <lorenzo@kernel.org>
  drivers/net/wireless/ath/ath9k/dynack.c | 20 +++++++++++++-------
  1 file changed, 13 insertions(+), 7 deletions(-)
 
-diff --git a/drivers/net/wireless/ath/ath9k/dynack.c b/drivers/net/wireless/ath/ath9k/dynack.c
-index fe9181533de3..f786be04d0ac 100644
 --- a/drivers/net/wireless/ath/ath9k/dynack.c
 +++ b/drivers/net/wireless/ath/ath9k/dynack.c
 @@ -321,11 +321,9 @@ EXPORT_SYMBOL(ath_dynack_sample_ack_ts);
@@ -73,6 +71,3 @@ index fe9181533de3..f786be04d0ac 100644
  
        ah->hw->wiphy->features |= NL80211_FEATURE_ACKTO_ESTIMATION;
  }
--- 
-2.17.1
-
diff --git a/package/kernel/mac80211/patches/rt2x00/010-rt2x00-clear-IV-s-on-start-to-fix-AP-mode-regression.patch b/package/kernel/mac80211/patches/rt2x00/010-rt2x00-clear-IV-s-on-start-to-fix-AP-mode-regression.patch
deleted file mode 100644 (file)
index 8859c0d..0000000
+++ /dev/null
@@ -1,113 +0,0 @@
-From patchwork Mon Aug 19 11:20:07 2019
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-X-Patchwork-Submitter: Stanislaw Gruszka <sgruszka@redhat.com>
-X-Patchwork-Id: 11100685
-X-Patchwork-Delegate: kvalo@adurom.com
-Return-Path: <linux-wireless-owner@kernel.org>
-From: Stanislaw Gruszka <sgruszka@redhat.com>
-To: linux-wireless@vger.kernel.org
-Subject: [PATCH 5.3] rt2x00: clear IV's on start to fix AP mode regression
-Date: Mon, 19 Aug 2019 13:20:07 +0200
-Message-Id: <1566213607-6723-1-git-send-email-sgruszka@redhat.com>
-Sender: linux-wireless-owner@vger.kernel.org
-List-ID: <linux-wireless.vger.kernel.org>
-X-Mailing-List: linux-wireless@vger.kernel.org
-
-To do not brake HW restart we should keep initialization vectors data.
-I assumed that on start the data is already initialized to zeros, but
-that not true on some scenarios and we should clear it. So add
-additional flag to check if we are under HW restart and clear IV's
-data if we are not.
-
-Patch fixes AP mode regression.
-
-Reported-and-tested-by: Emil Karlson <jekarl@iki.fi>
-Fixes: 710e6cc1595e ("rt2800: do not nullify initialization vector data")
-Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
----
- drivers/net/wireless/ralink/rt2x00/rt2800lib.c |  9 +++++++++
- drivers/net/wireless/ralink/rt2x00/rt2x00.h    |  1 +
- drivers/net/wireless/ralink/rt2x00/rt2x00dev.c | 13 ++++++++-----
- 3 files changed, 18 insertions(+), 5 deletions(-)
-
---- a/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
-+++ b/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
-@@ -6095,6 +6095,15 @@ static int rt2800_init_registers(struct
-       }
-       /*
-+       * Clear encryption initialization vectors on start, but keep them
-+       * for watchdog reset. Otherwise we will have wrong IVs and not be
-+       * able to keep connections after reset.
-+       */
-+      if (!test_bit(DEVICE_STATE_RESET, &rt2x00dev->flags))
-+              for (i = 0; i < 256; i++)
-+                      rt2800_register_write(rt2x00dev, MAC_IVEIV_ENTRY(i), 0);
-+
-+      /*
-        * Clear all beacons
-        */
-       for (i = 0; i < 8; i++)
---- a/drivers/net/wireless/ralink/rt2x00/rt2x00.h
-+++ b/drivers/net/wireless/ralink/rt2x00/rt2x00.h
-@@ -658,6 +658,7 @@ enum rt2x00_state_flags {
-       DEVICE_STATE_ENABLED_RADIO,
-       DEVICE_STATE_SCANNING,
-       DEVICE_STATE_FLUSHING,
-+      DEVICE_STATE_RESET,
-       /*
-        * Driver configuration
---- a/drivers/net/wireless/ralink/rt2x00/rt2x00dev.c
-+++ b/drivers/net/wireless/ralink/rt2x00/rt2x00dev.c
-@@ -1256,13 +1256,14 @@ static int rt2x00lib_initialize(struct r
- int rt2x00lib_start(struct rt2x00_dev *rt2x00dev)
- {
--      int retval;
-+      int retval = 0;
-       if (test_bit(DEVICE_STATE_STARTED, &rt2x00dev->flags)) {
-               /*
-                * This is special case for ieee80211_restart_hw(), otherwise
-                * mac80211 never call start() two times in row without stop();
-                */
-+              set_bit(DEVICE_STATE_RESET, &rt2x00dev->flags);
-               rt2x00dev->ops->lib->pre_reset_hw(rt2x00dev);
-               rt2x00lib_stop(rt2x00dev);
-       }
-@@ -1273,14 +1274,14 @@ int rt2x00lib_start(struct rt2x00_dev *r
-        */
-       retval = rt2x00lib_load_firmware(rt2x00dev);
-       if (retval)
--              return retval;
-+              goto out;
-       /*
-        * Initialize the device.
-        */
-       retval = rt2x00lib_initialize(rt2x00dev);
-       if (retval)
--              return retval;
-+              goto out;
-       rt2x00dev->intf_ap_count = 0;
-       rt2x00dev->intf_sta_count = 0;
-@@ -1289,11 +1290,13 @@ int rt2x00lib_start(struct rt2x00_dev *r
-       /* Enable the radio */
-       retval = rt2x00lib_enable_radio(rt2x00dev);
-       if (retval)
--              return retval;
-+              goto out;
-       set_bit(DEVICE_STATE_STARTED, &rt2x00dev->flags);
--      return 0;
-+out:
-+      clear_bit(DEVICE_STATE_RESET, &rt2x00dev->flags);
-+      return retval;
- }
- void rt2x00lib_stop(struct rt2x00_dev *rt2x00dev)
diff --git a/package/kernel/mac80211/patches/rt2x00/011-rt2x00-clear-up-IV-s-on-key-removal.patch b/package/kernel/mac80211/patches/rt2x00/011-rt2x00-clear-up-IV-s-on-key-removal.patch
deleted file mode 100644 (file)
index 7f3f139..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-From patchwork Fri Aug 23 12:48:03 2019
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-X-Patchwork-Submitter: Stanislaw Gruszka <sgruszka@redhat.com>
-X-Patchwork-Id: 11111605
-X-Patchwork-Delegate: kvalo@adurom.com
-From: Stanislaw Gruszka <sgruszka@redhat.com>
-To: linux-wireless@vger.kernel.org
-Subject: [PATCH 5.3] rt2x00: clear up IV's on key removal
-Date: Fri, 23 Aug 2019 14:48:03 +0200
-Message-Id: <1566564483-31088-1-git-send-email-sgruszka@redhat.com>
-Sender: linux-wireless-owner@vger.kernel.org
-List-ID: <linux-wireless.vger.kernel.org>
-X-Mailing-List: linux-wireless@vger.kernel.org
-
-After looking at code I realized that my previous fix
-95844124385e ("rt2x00: clear IV's on start to fix AP mode regression")
-was incomplete. We can still have wrong IV's after re-keyring.
-To fix that, clear up IV's also on key removal.
-
-Fixes: 710e6cc1595e ("rt2800: do not nullify initialization vector data")
-Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
----
- drivers/net/wireless/ralink/rt2x00/rt2800lib.c | 19 ++++++++++++-------
- 1 file changed, 12 insertions(+), 7 deletions(-)
-
---- a/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
-+++ b/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
-@@ -1654,13 +1654,18 @@ static void rt2800_config_wcid_attr_ciph
-       offset = MAC_IVEIV_ENTRY(key->hw_key_idx);
--      rt2800_register_multiread(rt2x00dev, offset,
--                                &iveiv_entry, sizeof(iveiv_entry));
--      if ((crypto->cipher == CIPHER_TKIP) ||
--          (crypto->cipher == CIPHER_TKIP_NO_MIC) ||
--          (crypto->cipher == CIPHER_AES))
--              iveiv_entry.iv[3] |= 0x20;
--      iveiv_entry.iv[3] |= key->keyidx << 6;
-+      if (crypto->cmd == SET_KEY) {
-+              rt2800_register_multiread(rt2x00dev, offset,
-+                                        &iveiv_entry, sizeof(iveiv_entry));
-+              if ((crypto->cipher == CIPHER_TKIP) ||
-+                  (crypto->cipher == CIPHER_TKIP_NO_MIC) ||
-+                  (crypto->cipher == CIPHER_AES))
-+                      iveiv_entry.iv[3] |= 0x20;
-+              iveiv_entry.iv[3] |= key->keyidx << 6;
-+      } else {
-+              memset(&iveiv_entry, 0, sizeof(iveiv_entry));
-+      }
-+
-       rt2800_register_multiwrite(rt2x00dev, offset,
-                                  &iveiv_entry, sizeof(iveiv_entry));
- }
diff --git a/package/kernel/mac80211/patches/rt2x00/016-rt2x00-revert-rt2800-enable-TX_PIN_CFG_LNA_PE_-bits-per-band.patch b/package/kernel/mac80211/patches/rt2x00/016-rt2x00-revert-rt2800-enable-TX_PIN_CFG_LNA_PE_-bits-per-band.patch
deleted file mode 100644 (file)
index 3fcf231..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-From patchwork Thu Aug 29 11:29:59 2019
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-X-Patchwork-Submitter: Stanislaw Gruszka <sgruszka@redhat.com>
-X-Patchwork-Id: 11121089
-X-Patchwork-Delegate: kvalo@adurom.com
-From: Stanislaw Gruszka <sgruszka@redhat.com>
-To: linux-wireless@vger.kernel.org
-Subject: [PATCH 5.3] Revert "rt2800: enable TX_PIN_CFG_LNA_PE_ bits per band"
-Date: Thu, 29 Aug 2019 13:29:59 +0200
-Message-Id: <1567078199-3645-1-git-send-email-sgruszka@redhat.com>
-Sender: linux-wireless-owner@vger.kernel.org
-List-ID: <linux-wireless.vger.kernel.org>
-X-Mailing-List: linux-wireless@vger.kernel.org
-
-This reverts commit 9ad3b55654455258a9463384edb40077439d879f.
-
-As reported by Sergey:
-
-"I got some problem after upgrade kernel to 5.2 version (debian testing
-linux-image-5.2.0-2-amd64). 5Ghz client  stopped to see AP.
-Some tests with 1metre distance between client-AP: 2.4Ghz  -22dBm, for
-5Ghz - 53dBm !, for longer distance (8m + walls) 2.4 - 61dBm, 5Ghz not
-visible."
-
-It was identified that rx signal level degradation was caused by
-9ad3b5565445 ("rt2800: enable TX_PIN_CFG_LNA_PE_ bits per band").
-So revert this commit.
-
-Cc: <stable@vger.kernel.org> # v5.1+
-Reported-and-tested-by: Sergey Maranchuk <slav0nic0@gmail.com>
-Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
----
- drivers/net/wireless/ralink/rt2x00/rt2800lib.c | 18 ++++++------------
- 1 file changed, 6 insertions(+), 12 deletions(-)
-
---- a/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
-+++ b/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
-@@ -4242,24 +4242,18 @@ static void rt2800_config_channel(struct
-       switch (rt2x00dev->default_ant.rx_chain_num) {
-       case 3:
-               /* Turn on tertiary LNAs */
--              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_A2_EN,
--                                 rf->channel > 14);
--              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_G2_EN,
--                                 rf->channel <= 14);
-+              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_A2_EN, 1);
-+              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_G2_EN, 1);
-               /* fall-through */
-       case 2:
-               /* Turn on secondary LNAs */
--              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_A1_EN,
--                                 rf->channel > 14);
--              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_G1_EN,
--                                 rf->channel <= 14);
-+              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_A1_EN, 1);
-+              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_G1_EN, 1);
-               /* fall-through */
-       case 1:
-               /* Turn on primary LNAs */
--              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_A0_EN,
--                                 rf->channel > 14);
--              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_G0_EN,
--                                 rf->channel <= 14);
-+              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_A0_EN, 1);
-+              rt2x00_set_field32(&tx_pin, TX_PIN_CFG_LNA_PE_G0_EN, 1);
-               break;
-       }
index 634c531b009d43f9677f5e3e82e899d4af7f4213..11115f45bc1680f382f72626aa403d1810c880d0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/mac80211/cfg.c
 +++ b/net/mac80211/cfg.c
-@@ -2319,7 +2319,7 @@ static int ieee80211_scan(struct wiphy *
+@@ -2314,7 +2314,7 @@ static int ieee80211_scan(struct wiphy *
                 * the  frames sent while scanning on other channel will be
                 * lost)
                 */
index af70b46fdcfc10a6ee4e608613fb359769a2f876..99b17faccd85759f0134139a6ce49919886b836f 100644 (file)
@@ -64,7 +64,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __NL80211_SURVEY_INFO_AFTER_LAST,
 --- a/net/wireless/nl80211.c
 +++ b/net/wireless/nl80211.c
-@@ -8694,6 +8694,10 @@ static int nl80211_send_survey(struct sk
+@@ -8729,6 +8729,10 @@ static int nl80211_send_survey(struct sk
            nla_put_u64_64bit(msg, NL80211_SURVEY_INFO_TIME_SCAN,
                              survey->time_scan, NL80211_SURVEY_INFO_PAD))
                goto nla_put_failure;
index a76953933f7dbff2010b09b2381ca42f1e7503cd..5977995b219b59c83e11bb0df90bd067abdf6b2c 100644 (file)
@@ -57,7 +57,7 @@
        __NL80211_ATTR_AFTER_LAST,
 --- a/net/mac80211/cfg.c
 +++ b/net/mac80211/cfg.c
-@@ -2584,6 +2584,19 @@ static int ieee80211_get_tx_power(struct
+@@ -2579,6 +2579,19 @@ static int ieee80211_get_tx_power(struct
        return 0;
  }
  
@@ -77,7 +77,7 @@
  static int ieee80211_set_wds_peer(struct wiphy *wiphy, struct net_device *dev,
                                  const u8 *addr)
  {
-@@ -3997,6 +4010,7 @@ const struct cfg80211_ops mac80211_confi
+@@ -3992,6 +4005,7 @@ const struct cfg80211_ops mac80211_confi
        .set_wiphy_params = ieee80211_set_wiphy_params,
        .set_tx_power = ieee80211_set_tx_power,
        .get_tx_power = ieee80211_get_tx_power,
        local->user_power_level = IEEE80211_UNSET_POWER_LEVEL;
 --- a/net/wireless/nl80211.c
 +++ b/net/wireless/nl80211.c
-@@ -574,6 +574,7 @@ const struct nla_policy nl80211_policy[N
+@@ -607,6 +607,7 @@ const struct nla_policy nl80211_policy[N
        [NL80211_ATTR_SAE_PASSWORD] = { .type = NLA_BINARY,
                                        .len = SAE_PASSWORD_MAX_LEN },
        [NL80211_ATTR_TWT_RESPONDER] = { .type = NLA_FLAG },
  };
  
  /* policy for the key attributes */
-@@ -2869,6 +2870,20 @@ static int nl80211_set_wiphy(struct sk_b
+@@ -2904,6 +2905,20 @@ static int nl80211_set_wiphy(struct sk_b
                if (result)
                        return result;
        }