Minor kernel build changes: Change '[ -d ... ] && cmd' to 'if [ -d ... ]; then cmd...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 4 Feb 2007 19:36:11 +0000 (19:36 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 4 Feb 2007 19:36:11 +0000 (19:36 +0000)
SVN-Revision: 6263

include/kernel-build.mk

index c0b17aa84115a4929f54e65fb103d43f153340a6..1ac847e93c4a4fc14df7c6669781b56bd4b9fbe0 100644 (file)
@@ -69,8 +69,9 @@ endif
 
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | tar -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       [ -d $(GENERIC_PLATFORM_DIR)/patches ] && $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches 
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+       if [ -d $(GENERIC_PLATFORM_DIR)/patches ]; then $(PATCH) $(LINUX_DIR) $(GENERIC_PLATFORM_DIR)/patches; fi
+       if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
+       if [ -d ./patches ]; then $(PATCH) $(LINUX_DIR) ./patches; fi
 endef
 define Kernel/Prepare
        $(call Kernel/Prepare/Default)