pass opkg offline root as command line arg, solves caching issues when switching...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Sep 2010 21:05:51 +0000 (21:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Sep 2010 21:05:51 +0000 (21:05 +0000)
SVN-Revision: 22990

include/package-ipkg.mk

index 9212c1ff92ccdecee74bf7e7544689fd86aaff0b..0ac6bb53f685c22130cdf450b92ce52b12b21ffe 100644 (file)
@@ -13,6 +13,7 @@ OPKG:= \
   IPKG_OFFLINE_ROOT=$(TARGET_DIR) \
   $(STAGING_DIR_HOST)/bin/opkg \
        -f $(STAGING_DIR)/etc/opkg.conf \
+       --offline-root $(TARGET_DIR) \
        --force-depends \
        --force-overwrite \
        --force-run-hooks
@@ -126,7 +127,6 @@ ifeq ($(DUMP),)
        mkdir -p $(STAGING_DIR)/etc
        ( echo "dest root /"                            > $@; \
          echo "arch all 100"                           >> $@; \
-         echo "arch $(PKGARCH) 200"                    >> $@; \
-         echo "option offline_root $(TARGET_DIR)"      >> $@ )
+         echo "arch $(PKGARCH) 200"                    >> $@ )
 
 endif