linux: update 3.0 to 3.0.12
authorJonas Gorski <jogo@openwrt.org>
Tue, 6 Dec 2011 19:50:25 +0000 (19:50 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 6 Dec 2011 19:50:25 +0000 (19:50 +0000)
SVN-Revision: 29469

include/kernel-version.mk
target/linux/brcm47xx/Makefile
target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch
target/linux/malta/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/uml/patches-3.0/004-fix_atomic64_32.patch

index 3220afaf4bec237e3880e9ba5c06b4ff2a2035c8..dec2412be644e4e650b924506afd52c7a3122baf 100644 (file)
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.9)
-  LINUX_KERNEL_MD5SUM:=71992fa4dfc289a959f9ce266d08d77b
+ifeq ($(LINUX_VERSION),3.0.12)
+  LINUX_KERNEL_MD5SUM:=aa5d56ddc2ef01a61759ceeb0f6b8308
 endif
 ifeq ($(LINUX_VERSION),3.1.1)
   LINUX_KERNEL_MD5SUM:=4db653798a325f759b8cf49a1b5e6011
index ea18b7c772fffb437ca8098f6c6d771c3883ae8c..eb4d9aff9a30d08f135e24d1ed6bbb70aa1a3ed3 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.9
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 3bbadd42a8c3bd02e5ccd5fbb0776654c0f65b47..49a88ec7e2d93da61105c7962794f55eaf4a0ca5 100644 (file)
@@ -10,7 +10,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -883,3 +885,5 @@ static void __devinit quirk_usb_early_ha
+@@ -882,3 +884,5 @@ static void __devinit quirk_usb_early_ha
                quirk_usb_handoff_xhci(pdev);
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
index 03be924846d6f954bad0906e1cab10f9df3ba53f..7495e2fd1ae035d6d2a1474e8503ce3a1c0d1078 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.9
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 
index fcd0bb5eabe78bae02bf904df9a5e9ef99118c16..cf650fae98c47e8ae8b3cd1f603ada67977996ea 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.9
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 450849d5d36b2a44fda46b9e82af4d56998a3391..6164d9ddc1c000326b275eb9c8e422a31990993e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.9
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 
index be09630254e8b68150f6f9542a0a7b2d7112cf04..94de710558009e1bcf0c44d07fe9c23f17dcee70 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.9
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 
index f6c4586e28878778736cf83a76883eab7ee28914..244d8339d690a54ba44aa5cb04654c9e57cbe1a7 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.9
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 
index 6901eee210694f5bea3586ef5ae6070b6684fa83..fe1e48fc42e51bab04d5e5558bcc02cce1009fdf 100644 (file)
@@ -2,7 +2,7 @@
 
 --- a/arch/um/sys-i386/Makefile
 +++ b/arch/um/sys-i386/Makefile
-@@ -8,7 +8,7 @@ obj-y = bug.o bugs.o checksum.o delay.o 
+@@ -8,7 +8,7 @@ obj-y = bug.o bugs.o checksum.o delay.o
  
  obj-$(CONFIG_BINFMT_ELF) += elfcore.o