curl: only set ca path for openssl
authorFelix Fietkau <nbd@openwrt.org>
Thu, 25 Sep 2014 10:51:56 +0000 (10:51 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 25 Sep 2014 10:51:56 +0000 (10:51 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42662

package/network/utils/curl/Makefile

index 2c6e6ea2b7b585360e0b876ff923acdf3d7f05e0..a77fcc89a7d6262870e979e1f00cc1ef1a78e0fd 100644 (file)
@@ -97,7 +97,7 @@ CONFIGURE_ARGS += \
        --disable-manual \
        --disable-verbose \
        --without-ca-bundle \
-       --with-ca-path=/etc/ssl/certs/ \
+       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ca-path=/etc/ssl/certs/) \
        --without-krb4 \
        --without-libidn \
        --without-nss \