build: allow overriding the filename on the remote server when downloading
authorFelix Fietkau <nbd@nbd.name>
Thu, 22 Feb 2018 16:26:41 +0000 (17:26 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 12 Aug 2019 09:43:38 +0000 (11:43 +0200)
Github releases usually don't contain the project name in the release
filename, which makes them very inconvenient to use from the build
system. Add support for naming the local file differently.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/download.mk

index 09794e155e9f2ab17918d21dcf8d9930d66efe65..14d68bf8f5e929fb4bdf6908f0d428c2d584f19e 100644 (file)
@@ -289,6 +289,7 @@ endef
 define Download/default
   FILE:=$(PKG_SOURCE)
   URL:=$(PKG_SOURCE_URL)
+  URL_FILE:=$(PKG_SOURCE_URL_FILE)
   SUBDIR:=$(PKG_SOURCE_SUBDIR)
   PROTO:=$(PKG_SOURCE_PROTO)
   $(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))