kernel/modules: Enable Realtek R8169 not only for x86
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Thu, 7 Apr 2011 23:31:56 +0000 (23:31 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Thu, 7 Apr 2011 23:31:56 +0000 (23:31 +0000)
This enables support for Realtek 8169 based network cards for other
platforms than x86. I have a mini-PCI card on ixp4xxx running here.
Maybe for the other cards in netdevices.mk a @DEPENDS change from
@TARGET_x86 to @PCI_SUPPORT makes also sense.

Signed-off-by: Christoph König <christoph.koenig@ikt.uni-hannover.de>
SVN-Revision: 26529

package/kernel/modules/netdevices.mk

index e8036f0e003b55fb702a13da17be2c54fc02bb0e..762a171773f1ba56f7b93f867a4ce0ce5cf9bf10 100644 (file)
@@ -224,7 +224,7 @@ $(eval $(call KernelPackage,8139cp))
 define KernelPackage/r8169
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
 define KernelPackage/r8169
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@PCI_SUPPORT
   KCONFIG:=CONFIG_R8169 \
     CONFIG_R8169_NAPI=y \
     CONFIG_R8169_VLAN=n
   KCONFIG:=CONFIG_R8169 \
     CONFIG_R8169_NAPI=y \
     CONFIG_R8169_VLAN=n