ar71xx: fix seama factory type image generation.
authorJohn Crispin <john@openwrt.org>
Tue, 14 Oct 2014 12:21:41 +0000 (12:21 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 14 Oct 2014 12:21:41 +0000 (12:21 +0000)
Currently JFFS2 end-of-filesystem marker 0xdeadc0de is included the
computation of image's MD5 checksum as part of the seama header.  But
OpenWrt will erase blocks including and after the marker thus
invalidating the checksum after the first boot.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
SVN-Revision: 42915

target/linux/ar71xx/image/Makefile

index c307abef853626f1d53b5d4936708190e58f4cb3..78e2d705cec5582c21001083c2a715fde397975f 100644 (file)
@@ -673,13 +673,15 @@ define Image/Build/Seama
        -rm -f $(KDIR_TMP)/image-$(2).tmp
        $(call CatFiles,$(KDIR_TMP)/loader-$(2).bin.lzma,$$$$(($(6) - 64)),$(KDIR)/root.$(1),$(7),$(KDIR_TMP)/image-$(2).tmp)
        [ -e "$(KDIR_TMP)/image-$(2).tmp" ] && { \
        -rm -f $(KDIR_TMP)/image-$(2).tmp
        $(call CatFiles,$(KDIR_TMP)/loader-$(2).bin.lzma,$$$$(($(6) - 64)),$(KDIR)/root.$(1),$(7),$(KDIR_TMP)/image-$(2).tmp)
        [ -e "$(KDIR_TMP)/image-$(2).tmp" ] && { \
+               head -c -4 "$(KDIR_TMP)/image-$(2).tmp" > "$(KDIR_TMP)/image-$(2).no-jffs2mark.tmp"; \
                $(STAGING_DIR_HOST)/bin/seama \
                $(STAGING_DIR_HOST)/bin/seama \
-               -i $(KDIR_TMP)/image-$(2).tmp \
+               -i $(KDIR_TMP)/image-$(2).no-jffs2mark.tmp \
                -m "dev=/dev/mtdblock/1" -m "type=firmware"; \
                $(STAGING_DIR_HOST)/bin/seama \
                        -s $(call imgname,$(1),$(2))-factory.bin \
                        -m "signature=$(5)" \
                -m "dev=/dev/mtdblock/1" -m "type=firmware"; \
                $(STAGING_DIR_HOST)/bin/seama \
                        -s $(call imgname,$(1),$(2))-factory.bin \
                        -m "signature=$(5)" \
-                       -i $(KDIR_TMP)/image-$(2).tmp.seama; \
+                       -i $(KDIR_TMP)/image-$(2).no-jffs2mark.tmp.seama; \
+               tail -c 4 "$(KDIR_TMP)/image-$(2).tmp" >> $(call imgname,$(1),$(2))-factory.bin; \
        }
        cat $(KDIR_TMP)/loader-$(2).bin.lzma > $(KDIR_TMP)/image-$(2)-sysupgrade.tmp
        $(STAGING_DIR_HOST)/bin/seama \
        }
        cat $(KDIR_TMP)/loader-$(2).bin.lzma > $(KDIR_TMP)/image-$(2)-sysupgrade.tmp
        $(STAGING_DIR_HOST)/bin/seama \