kernel/modules: add native vxlan package
authorJohn Crispin <john@openwrt.org>
Fri, 31 Oct 2014 11:01:28 +0000 (11:01 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 31 Oct 2014 11:01:28 +0000 (11:01 +0000)
More recent kernel versions (>= 3.12) support native VXLAN
support.

The Open VSwitch kernel module tries to build using native VXLAN
support if it detects a kernel version >=3.12.

The build works fine, but during startup the OVS kernel module
does not load.
dmesg output is something like this:
    [ 1201.262842] openvswitch: Unknown symbol vxlan_sock_release
    [ 1201.262949] openvswitch: Unknown symbol vxlan_xmit_skb
    [ 1201.263161] openvswitch: Unknown symbol vxlan_sock_add

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
SVN-Revision: 43126

package/kernel/linux/modules/netsupport.mk

index fc85e22f41faef17ab02a97401516d0b8352fdae..376b588982964f3fe89e1e0ba9f4fa6cc9bd09bc 100644 (file)
@@ -144,6 +144,20 @@ endef
 
 $(eval $(call KernelPackage,8021q))
 
+define KernelPackage/vxlan
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Native VXLAN Kernel support
+  KCONFIG:=CONFIG_VXLAN
+  FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
+  AUTOLOAD:=$(call AutoLoad,13,vxlan)
+endef
+
+define KernelPackage/vxlan/description
+ Kernel module for supporting VXLAN in the Kernel.
+ Requires Kernel 3.12 or newer.
+endef
+
+$(eval $(call KernelPackage,vxlan))
 
 define KernelPackage/capi
   SUBMENU:=$(NETWORK_SUPPORT_MENU)