refresh kernel patches
authorGabor Juhos <juhosg@openwrt.org>
Mon, 19 May 2008 12:11:46 +0000 (12:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 19 May 2008 12:11:46 +0000 (12:11 +0000)
SVN-Revision: 11210

target/linux/rdc/patches/001-rdc3210_flash_map.patch
target/linux/rdc/patches/001-x86_generic_gpio.patch
target/linux/rdc/patches/002-r6040_ethernet.patch
target/linux/rdc/patches/003-rootfstype.patch
target/linux/rdc/patches/004-rdc_fixes.patch
target/linux/rdc/patches/006-pci_ids.patch
target/linux/rdc/patches/600-x86_lzma.patch

index 0c407a114aa933a5a06a3e5f211a55c0b7de8eae..ec80e30e5bdf867c1d9b3f648b665d23f5f3b540 100644 (file)
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig
---- linux-2.6.17/drivers/mtd/maps/Kconfig      2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig  2006-09-24 20:28:11.000000000 +0200
-@@ -76,6 +76,50 @@
+Index: linux-2.6.24.7/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.24.7.orig/drivers/mtd/maps/Kconfig
++++ linux-2.6.24.7/drivers/mtd/maps/Kconfig
+@@ -117,6 +117,50 @@ config MTD_PNC2000
          PNC-2000 is the name of Network Camera product from PHOTRON
          Ltd. in Japan. It uses CFI-compliant flash.
  
@@ -52,11 +53,12 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/map
  config MTD_SC520CDP
        tristate "CFI Flash device mapped on AMD SC520 CDP"
        depends on X86 && MTD_CFI && MTD_CONCAT
-diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile
---- linux-2.6.17/drivers/mtd/maps/Makefile     2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200
-@@ -28,6 +28,7 @@
- obj-$(CONFIG_MTD_PHYSMAP)     += physmap.o
+Index: linux-2.6.24.7/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.24.7.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.24.7/drivers/mtd/maps/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM)   += pmcms
+ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
  obj-$(CONFIG_MTD_PNC2000)     += pnc2000.o
  obj-$(CONFIG_MTD_PCMCIA)      += pcmciamtd.o
 +obj-$(CONFIG_MTD_RDC3210)     += rdc3210.o
index ad2102f6321cfdd355a41c9afdb9d626d405674a..dff25a0cd98498ce2b1538115aeccea53d440dc2 100644 (file)
@@ -1,15 +1,15 @@
-diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index 97b64d7..f8c1d32 100644
---- a/arch/x86/Kconfig
-+++ b/arch/x86/Kconfig
-@@ -79,6 +79,10 @@ config GENERIC_BUG
-        default y
-        depends on BUG
-
+Index: linux-2.6.24.7/arch/x86/Kconfig
+===================================================================
+--- linux-2.6.24.7.orig/arch/x86/Kconfig
++++ linux-2.6.24.7/arch/x86/Kconfig
+@@ -81,6 +81,10 @@ config GENERIC_BUG
+       default y
+       depends on BUG
 +config GENERIC_GPIO
 +       bool
 +       default n
 +
  config GENERIC_HWEIGHT
-        bool
-        default y
+       bool
+       default y
index 1b930252476e1c88835d25b68564275c9413a3e6..fa484bf9e88e940d8f978f9eabdbd25dacf53b20 100644 (file)
@@ -1,9 +1,10 @@
-diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
---- linux-2.6.17/drivers/net/Kconfig   2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/net/Kconfig       2006-09-25 13:14:27.000000000 +0200
-@@ -1358,6 +1358,24 @@
-         <file:Documentation/networking/net-modules.txt>.  The module will be
-         called apricot.
+Index: linux-2.6.24.7/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.24.7.orig/drivers/net/Kconfig
++++ linux-2.6.24.7/drivers/net/Kconfig
+@@ -1449,6 +1449,24 @@ config APRICOT
+         To compile this driver as a module, choose M here. The module
+         will be called apricot.
  
 +config R6040
 +      tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
@@ -24,16 +25,17 @@ diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
 +      depends on R6040
 +      default y
  config B44
-       tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
-       depends on NET_PCI && PCI && EXPERIMENTAL
-diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile
---- linux-2.6.17/drivers/net/Makefile  2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/net/Makefile      2006-09-25 13:14:45.000000000 +0200
-@@ -106,6 +106,7 @@
+       tristate "Broadcom 440x/47xx ethernet support"
+       depends on SSB_POSSIBLE
+Index: linux-2.6.24.7/drivers/net/Makefile
+===================================================================
+--- linux-2.6.24.7.orig/drivers/net/Makefile
++++ linux-2.6.24.7/drivers/net/Makefile
+@@ -116,6 +116,7 @@ obj-$(CONFIG_LNE390) += lne390.o 8390.o
  obj-$(CONFIG_NE3210) += ne3210.o 8390.o
- obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o
+ obj-$(CONFIG_SB1250_MAC) += sb1250-mac.o
  obj-$(CONFIG_B44) += b44.o
 +obj-$(CONFIG_R6040) += r6040.o
  obj-$(CONFIG_FORCEDETH) += forcedeth.o
- obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o
+ obj-$(CONFIG_NE_H8300) += ne-h8300.o
+ obj-$(CONFIG_AX88796) += ax88796.o
index 34ac3d0a712ff0edc4d06d29bdc6795e82d1147b..15e002ad7f8f610d2009a69e9b401088519d83e3 100644 (file)
@@ -1,6 +1,8 @@
---- linux-2.6.19.2/init/do_mounts.c    2007-01-10 11:10:37.000000000 -0800
-+++ foo/init/do_mounts.c       2007-04-05 13:15:37.000000000 -0700
-@@ -243,6 +243,8 @@
+Index: linux-2.6.24.7/init/do_mounts.c
+===================================================================
+--- linux-2.6.24.7.orig/init/do_mounts.c
++++ linux-2.6.24.7/init/do_mounts.c
+@@ -256,6 +256,8 @@ static void __init get_fs_names(char *pa
  {
        char *s = page;
  
index 47f8c08c682a00433fede6a5fb253a2c82a99b09..ce5fbfda13f0c89194216012f9aeb494a9e2f7bd 100644 (file)
@@ -1,7 +1,8 @@
-diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
---- linux-2.6.24/arch/x86/Kconfig      2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/Kconfig  2008-02-11 18:24:27.000000000 +0100
-@@ -300,6 +300,17 @@
+Index: linux-2.6.24.7/arch/x86/Kconfig
+===================================================================
+--- linux-2.6.24.7.orig/arch/x86/Kconfig
++++ linux-2.6.24.7/arch/x86/Kconfig
+@@ -304,6 +304,17 @@ config X86_VSMP
          supposed to run on these EM64T-based machines.  Only choose this option
          if you have one of these machines.
  
@@ -19,10 +20,11 @@ diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
  endchoice
  
  config SCHED_NO_NO_OMIT_FRAME_POINTER
-diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c
---- linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c    2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c        2008-02-11 18:26:18.000000000 +0100
-@@ -30,6 +30,17 @@
+Index: linux-2.6.24.7/arch/x86/kernel/reboot_fixups_32.c
+===================================================================
+--- linux-2.6.24.7.orig/arch/x86/kernel/reboot_fixups_32.c
++++ linux-2.6.24.7/arch/x86/kernel/reboot_fixups_32.c
+@@ -30,6 +30,17 @@ static void cs5536_warm_reset(struct pci
        udelay(50); /* shouldn't get here but be safe and spin a while */
  }
  
@@ -40,7 +42,7 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
  struct device_fixup {
        unsigned int vendor;
        unsigned int device;
-@@ -40,6 +51,7 @@
+@@ -40,6 +51,7 @@ static struct device_fixup fixups_table[
  { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
  { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
  { PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
@@ -48,10 +50,11 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
  };
  
  /*
-diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_32
---- linux-2.6.24/arch/x86/Makefile_32  2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/Makefile_32      2008-02-11 18:25:12.000000000 +0100
-@@ -99,6 +99,11 @@
+Index: linux-2.6.24.7/arch/x86/Makefile_32
+===================================================================
+--- linux-2.6.24.7.orig/arch/x86/Makefile_32
++++ linux-2.6.24.7/arch/x86/Makefile_32
+@@ -99,6 +99,11 @@ mflags-$(CONFIG_X86_ES7000) := -Iinclude
  mcore-$(CONFIG_X86_ES7000)    := arch/x86/mach-default
  core-$(CONFIG_X86_ES7000)     := arch/x86/mach-es7000/
  
@@ -63,9 +66,10 @@ diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_3
  # Xen paravirtualization support
  core-$(CONFIG_XEN)            += arch/x86/xen/
  
-diff -urN linux-2.6.24/include/asm-x86/timex.h linux-2.6.24.new/include/asm-x86/timex.h
---- linux-2.6.24/include/asm-x86/timex.h       2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/include/asm-x86/timex.h   2008-02-11 18:25:43.000000000 +0100
+Index: linux-2.6.24.7/include/asm-x86/timex.h
+===================================================================
+--- linux-2.6.24.7.orig/include/asm-x86/timex.h
++++ linux-2.6.24.7/include/asm-x86/timex.h
 @@ -7,6 +7,8 @@
  
  #ifdef CONFIG_X86_ELAN
index cd4c01d920a842f5e29f59b634b5b248a2e79017..dbc33c2cd829ad484c9243734ae294d93059d6c2 100644 (file)
@@ -1,8 +1,8 @@
-diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
-index 55f307f..4a1aa34 100644
---- a/include/linux/pci_ids.h
-+++ b/include/linux/pci_ids.h
-@@ -2076,6 +2076,13 @@
+Index: linux-2.6.24.7/include/linux/pci_ids.h
+===================================================================
+--- linux-2.6.24.7.orig/include/linux/pci_ids.h
++++ linux-2.6.24.7/include/linux/pci_ids.h
+@@ -2106,6 +2106,13 @@
  #define PCI_DEVICE_ID_HERC_WIN                0x5732
  #define PCI_DEVICE_ID_HERC_UNI                0x5832
  
index 292ec88ff692e9c7a7d2131f4abef07d0ebf17a4..3bef6fa1a0bba0d7d4b3b5784fc6c40cf66e2b88 100644 (file)
@@ -1,6 +1,7 @@
-diff -Naur linux-old/arch/x86/boot/compressed/LzmaDecode.c linux-lzma/arch/i386/boot/compressed/LzmaDecode.c
---- linux-old/arch/x86/boot/compressed/LzmaDecode.c    1969-12-31 19:00:00.000000000 -0500
-+++ linux-lzma/arch/x86/boot/compressed/LzmaDecode.c   2005-06-05 00:07:38.000000000 -0400
+Index: linux-2.6.24.7/arch/x86/boot/compressed/LzmaDecode.c
+===================================================================
+--- /dev/null
++++ linux-2.6.24.7/arch/x86/boot/compressed/LzmaDecode.c
 @@ -0,0 +1,586 @@
 +/*
 +  LzmaDecode.c
@@ -588,9 +589,10 @@ diff -Naur linux-old/arch/x86/boot/compressed/LzmaDecode.c linux-lzma/arch/i386/
 +  *outSizeProcessed = nowPos;
 +  return LZMA_RESULT_OK;
 +}
-diff -Naur linux-old/arch/x86/boot/compressed/LzmaDecode.h linux-lzma/arch/i386/boot/compressed/LzmaDecode.h
---- linux-old/arch/x86/boot/compressed/LzmaDecode.h    1969-12-31 19:00:00.000000000 -0500
-+++ linux-lzma/arch/x86/boot/compressed/LzmaDecode.h   2005-06-05 00:07:39.000000000 -0400
+Index: linux-2.6.24.7/arch/x86/boot/compressed/LzmaDecode.h
+===================================================================
+--- /dev/null
++++ linux-2.6.24.7/arch/x86/boot/compressed/LzmaDecode.h
 @@ -0,0 +1,100 @@
 +/* 
 +  LzmaDecode.h
@@ -692,9 +694,10 @@ diff -Naur linux-old/arch/x86/boot/compressed/LzmaDecode.h linux-lzma/arch/i386/
 +    UInt32 *outSizeProcessed);
 +
 +#endif
-diff -Naur linux-old/arch/x86/boot/compressed/lzma_misc.c linux-lzma/arch/i386/boot/compressed/lzma_misc.c
---- linux-old/arch/x86/boot/compressed/lzma_misc.c     1969-12-31 19:00:00.000000000 -0500
-+++ linux-lzma/arch/x86/boot/compressed/lzma_misc.c    2005-06-04 21:33:48.000000000 -0400
+Index: linux-2.6.24.7/arch/x86/boot/compressed/lzma_misc.c
+===================================================================
+--- /dev/null
++++ linux-2.6.24.7/arch/x86/boot/compressed/lzma_misc.c
 @@ -0,0 +1,281 @@
 +/*
 + * lzma_misc.c
@@ -977,10 +980,11 @@ diff -Naur linux-old/arch/x86/boot/compressed/lzma_misc.c linux-lzma/arch/i386/b
 +      lzma_unzip();
 +      return;
 +}
-diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefile.lib
---- linux-2.6.19.2/scripts/Makefile.lib        2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/scripts/Makefile.lib    2007-04-15 23:51:54.000000000 +0200
-@@ -162,4 +162,9 @@
+Index: linux-2.6.24.7/scripts/Makefile.lib
+===================================================================
+--- linux-2.6.24.7.orig/scripts/Makefile.lib
++++ linux-2.6.24.7/scripts/Makefile.lib
+@@ -166,4 +166,9 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
  quiet_cmd_gzip = GZIP    $@
  cmd_gzip = gzip -f -9 < $< > $@
  
@@ -991,17 +995,19 @@ diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefil
 +cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0
 +# to use lzmacomp,
 +# cmd_lzma = lzmacomp $< 700 > $@
-diff -u linux/scripts/lzma_kern linux/scripts/lzma_kern
---- linux/scripts/lzma_kern    2007-07-27 20:18:17.013014750 -0700
-+++ linux/scripts/lzma_kern    2007-07-27 20:18:17.013014750 -0700
+Index: linux-2.6.24.7/scripts/lzma_kern
+===================================================================
+--- /dev/null
++++ linux-2.6.24.7/scripts/lzma_kern
 @@ -0,0 +1,4 @@
 +get-size() { echo "$5" ;}
 +printf -v len '%.8x' "$(get-size $(ls -l "$1"))"
 +lzma e "$@"
 +echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2"
-diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32
---- linux-2.6.24/arch/x86/boot/compressed/Makefile_32  2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32      2008-02-13 15:21:03.000000000 +0100
+Index: linux-2.6.24.7/arch/x86/boot/compressed/Makefile_32
+===================================================================
+--- linux-2.6.24.7.orig/arch/x86/boot/compressed/Makefile_32
++++ linux-2.6.24.7/arch/x86/boot/compressed/Makefile_32
 @@ -4,8 +4,8 @@
  # create a compressed vmlinux image from the original vmlinux
  #
@@ -1013,7 +1019,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
  EXTRA_AFLAGS  := -traditional
  
  LDFLAGS_vmlinux := -T
-@@ -17,7 +17,7 @@
+@@ -17,7 +17,7 @@ KBUILD_CFLAGS  := -m32 -D__KERNEL__ $(LI
           $(call cc-option,-fno-stack-protector)
  LDFLAGS := -m elf_i386
  
@@ -1022,7 +1028,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
        $(call if_changed,ld)
        @:
  
-@@ -37,14 +37,14 @@
+@@ -37,14 +37,14 @@ $(obj)/vmlinux.bin.all: $(vmlinux.bin.al
        $(call if_changed,relocbin)
  
  ifdef CONFIG_RELOCATABLE