brcm63xx: add a dummy image recipe for boards missing proper images
authorJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:34:26 +0000 (15:34 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:34:26 +0000 (15:34 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44981

target/linux/brcm63xx/image/Makefile

index 3c68cdbb11f6af2e0008b2ab5c1de7ae757bb681..a2130f3bd2e8aa15601f8d9b790a914dae4a18b8 100755 (executable)
@@ -106,6 +106,11 @@ define Image/Build/ChkDTB
        -k $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin -b $(5) -r $(6)
 endef
 
+define Image/Build/Dummy
+       # for boards without a flashable image yet
+       true
+endef
+
 define Build/Clean
        $(MAKE) -C lzma-loader clean
 endef
@@ -295,7 +300,7 @@ $(eval $(call ImageDTB,CFEDTB,HG556a_C,HG556a_C,hg556a-c,HW556,6358,--rsa-signat
 # Inventel Livebox 1
 $(eval $(call ImageDTB,RedBootDTB,Livebox,livebox,livebox-blue-5g))
 # Netgear CVG834G
-$(eval $(call ImageDTB,HCSDTB,CVG834G,,cvg834g,a020,0001,0022,vmlinux-cvg834g))
+$(eval $(call ImageDTB,Dummy,CVG834G,cvg834g,cvg834g,a020,0001,0022,vmlinux-cvg834g))
 # Netgear DG834GT/PN
 $(eval $(call ImageDTB,CFEDTB,DG834GTPN,DG834GT_PN,dg834gtpn,96348GW-10,6348))
 # Netgear DGND3700 v1 / DGND3800B