firewall: prevent redundant rules if multiple ports and multiple icmp types are given...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 26 Jul 2011 22:21:39 +0000 (22:21 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 26 Jul 2011 22:21:39 +0000 (22:21 +0000)
SVN-Revision: 27792

package/firewall/Makefile
package/firewall/files/lib/core_rule.sh

index 394a2075dfc406a6b4e9869b4094c3a71f8b1ee3..cdb8dc6224ca5185eda990e353c4673cc79dae9a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=32
+PKG_RELEASE:=33
 
 include $(INCLUDE_DIR)/package.mk
 
index 0a25fcd953af5fbf8821f97fa5b41d0654030877..de8cd8ea359b39eef25f6f0e5b6ea53c55814ef0 100644 (file)
@@ -67,21 +67,30 @@ fw_load_rule() {
 
        [ "$rule_proto" == "tcpudp" ] && rule_proto="tcp udp"
        local pr; for pr in $rule_proto; do
+               local sports dports itypes
+               case "$pr" in
+                       icmp|icmpv6|1|58)
+                               sports=""; dports=""
+                               itypes="$rule_icmp_type"
+                       ;;
+                       *)
+                               sports="$rule_src_port"
+                               dports="$rule_dest_port"
+                               itypes=""
+                       ;;
+               esac
+       
                fw_get_negation pr '-p' "$pr"
-               local sp; for sp in ${rule_src_port:-""}; do
+               local sp; for sp in ${sports:-""}; do
                        fw_get_port_range sp $sp
                        fw_get_negation sp '--sport' "$sp"
-                       local dp; for dp in ${rule_dest_port:-""}; do
+                       local dp; for dp in ${dports:-""}; do
                                fw_get_port_range dp $dp
                                fw_get_negation dp '--dport' "$dp"
                                local sm; for sm in ${rule_src_mac:-""}; do
                                        fw_get_negation sm '--mac-source' "$sm"
-                                       local it; for it in ${rule_icmp_type:-""}; do
+                                       local it; for it in ${itypes:-""}; do
                                                fw_get_negation it '--icmp-type' "$it"
-                                               case "$pr" in
-                                                       *" icmp"|*" icmpv6"|*" 1"|*" 58") sp=""; dp="" ;;
-                                                       *) it="" ;;
-                                               esac
                                                fw add $mode $table $chain $target + \
                                                        { $rule_src_ip $rule_dest_ip } { \
                                                        $src_spec $dest_spec \