gmp: add host compile
authorJohn Crispin <john@openwrt.org>
Mon, 18 Aug 2014 13:10:11 +0000 (13:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 18 Aug 2014 13:10:11 +0000 (13:10 +0000)
Currently, any package that uses host compile and depends on
libgmp.so will fail. This is because gmp is not compile for
host machine. So, staging_dir/host has only static lib for gmp

 $ ls staging_dir/host/lib/libgmp* -1
 staging_dir/host/lib/libgmp.a
 staging_dir/host/lib/libgmp.la
 staging_dir/host/lib/libgmpxx.a
 staging_dir/host/lib/libgmpxx.la

Addind host compile in gmp, the dependent package can use:

 PKG_BUILD_DEPENDS:=gmp/host

That will compile gmp to staging_dir/host with *.so files

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
SVN-Revision: 42196

package/libs/gmp/Makefile

index a165131acf283c27833071f87f8091e43658defe..f5839b74bbf93248defaca0d60b27ff24366ee38 100644 (file)
@@ -22,6 +22,7 @@ PKG_FIXUP:=autoreconf
 
 PKG_USE_MIPS16:=0
 
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libgmp
@@ -44,7 +45,6 @@ CONFIGURE_ARGS += \
        --without-readline \
        --disable-fft \
 
-
 define Build/Compile
        $(call Build/Compile/Default, \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -66,3 +66,4 @@ define Package/libgmp/install
 endef
 
 $(eval $(call BuildPackage,libgmp))
+$(eval $(call HostBuild))